CIS crash causing all processes crash and BSOD

A. The bug/issue

  1. What you did: used computer normally- I was typing in notepad. Had recently checked to enable advanced protection, but was finishing up some code before restarting.
  2. What actually happened or you actually saw: Every character in every open document turned into squares, the time in the bottom right was replaced by a couple of lines of Chinese characters, almost every application I had open at the time said exception 0x1 had occurred (I believe that’s memory?), clicking on shortcuts didn’t do anything and I couldn’t open any programs, dllhost.exe took up 2gb in task manager, and when I tried to dump it to disk windows said it couldn’t find drive c, and when I clicked restart the attached error message popped up- clicking ok did nothing, so I clicked the x and got a BSOD. Memcheck reports all good.
  3. What you expected to happen or see: none of the above :-p.
  4. How you tried to fix it & what happened: nope
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: nope
  8. Any other information (eg your guess regarding the cause, with reasons): comodo driver overwrote memory it shouldn’t have, started a cascade of awful

B. Files appended. (Please zip unless screenshots).

  1. Screenshots of the Defense plus Active Processes List (Required for all issues): attached
  2. Screenshots illustrating the bug: attached
  3. Screenshots of related CIS event logs: no logs for this
  4. A CIS config report or file. attached
  5. Crash or freeze dump file: dump is 1.2gb in size, attached windbg output. Willing to upload at dev request.
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: attached screenshot, configuration=internet security
  2. a) Have you updated (without uninstall) from from a previous version of CIS: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+= safe, Sandbox= enabled, Firewall = safe, AV = on access
  6. OS version, service pack, number of bits, UAC setting, & account type: win7ult s1 64x, UAC on, admin, also attached screenshot
  7. Other security and utility software currently installed: none
  8. Other security software previously installed at any time since Windows was last installed: none
  9. Virtual machine used (Please do NOT use Virtual box): none, only installed post event

[attachment deleted by admin]

Hi zxctypo,

Can you please attach the zipped version of the .dmp file as it contains more info that is needed to troubleshoot this issue.
From first look at it it doesn’t blame CIS components.

First time I found problem when mTorrent and one of trusted applications were working. BSOD appeared again when i used different applications for various periods. I saw it three or more times and used BlueScreenView utility for help.
May be i am making mistake, but i think trouble is in QoS service or cmdguard.sys driver, because i have last nVidea driver updates/ ???
Some forums writes that conflict of firewall and nVidea drivers is a reason
Another ones writes that conflict of DEP(Data Execution Prevention) with firewall causes this BSOD. I will try to turn off DEP and watch…
And re-installing network adapter drivers led to nothing. (It is one way of solving problem, i saw in forums)
Thanks for your help… (And i could not add screenshots, clicking on insert image… why?)

Thanks for the additional information.

Images can be embedded by using the button below the [I] from Italic.

Or by attaching them to the forum clicking on >Additional Options… Attach → Browse.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again