CIS cmdagent.exe slowdowns [Issue Report]

CIS cmdagent.exe slowdowns

The bug/issue

  1. What you did: Updated to the latest version of CIS and started to notice slowdowns.
  2. What actually happened or you actually saw: 50 to 100% cpu usage on cmdagent.exe when trying to start some programs, also the task bar freezes up when this happens but not the background, saw the cpu usage go up on bootup too and noticed it was cmdagent.exe again.
  3. What you expected to happen or see: The programs to start right away and not freezeup temporary thanks to cmdagent.exe.
  4. How you tried to fix it & what happened: Uninstalled and reinstalled also did a reinstall after trying the cleaning tool from here on the forums, didn’t help.
  5. If it’s an application compatibility problem have you tried the application fixes here?: none
  6. Details & exact version of any application (except CIS) involved with download link: so far i’ve noticed this behavior on WhereIsIt and the game Trains and Trucks Tycoon, no download links but i bet there are more.
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes. just start the programs and they will temporary hang untill cmdagent.exe lets them go and the cpu values return to normal.
  8. Any other information (eg your guess regarding the cause, with reasons): no

Files appended

  1. Screenshots illustrating the bug: yes
  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: none
  3. A CIS config. report or file: none
  4. Crash or freeze dump file: none

Your set-up

  1. CIS version, AV database version & configuration used: 5.4.189822.1355, 8715, Internet security config
  2. a) Have you updated (without uninstall) from CIS 3 or 4: Not relevant
    b) if so, have you tried reinstalling (if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a preset config (if not please do)?:
  4. Have you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security level: D+=disabled, Sandbox=disabled, Firewall=Custom policy, AV=Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP Pro, SP3, 32 bit, None in XP, Admin account.
  7. Other security and utility software installed: Spybot, Malwarebytes’ Anti-Malware
  8. Virtual machine used: none

[attachment deleted by admin]

My PC suffers apparently random periods of high cmdagent cpu and locks up the PC - my wife’s PC locks up for several minutes.

Other users are having problems also - see this post :-
https://forums.comodo.com/news-announcements-feedback-cis/cmdagent-taking-up-cpu-slows-down-everything-t69191.0.html;msg514968#msg514968[url]] https://forums.comodo.com/news-announcements-feedback-cis/cmdagent-taking-up-cpu-slows-down-everything-t69191.0.html;msg514968#msg514968[url][/url]

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis

I just wanted to point to this topic where Elvi and I along with others are discussing this.

problems “seems” to be resolved with these last 2 updates .1382 and .1383.
the programs and the taskbar havn’t forzen as of yet.

Subscribe to the above, Elvi!
I have the same problem.


http://screendepo.com/upload/1602/minu-20110725141827728.jpeg

CIS version, AV database version & configuration used: 5.4.189822.1355, 9504, Internet security config.

With some mods we are making a work around until this is fixed (i guess with white list update, only).
Under a Vista64bit system i had high CPU and disk usage (launch resource checker from Shift+Ctrl+Esc task manager and check disk usage), we solved the problems by adding files to the Exlusion list and i also disabled Windows Search services.

The programs i’ve added to the list:
SmartDefrag - defrag application.
Total Commander - a file manager.
360 Amigo - startup watcher.
Daemon Tools - optical disc emulator.

After adding these files and a CIS restart and a reboot (maybe not needed, i saw the result after a minute), the problem was solved.

Where to add:

  1. AV - scanner settings’ last tab.
  2. Defense+ - D+ settings, Execution Control Settings (2nd tab), Exlusions.

I also had alerts about files which were in directories i haven’t visited since months. I hope this helps.

Ark

I am using CIS ver 5.5.195786.1383 and cmdagent.exe is still running at 90-99% CPU usage. For me, it is not fixed.

I have the 1383 version of CIS installed and cmdagent is giving me about 140 memory hard faults/ sec. where my next application - Firefox is giving only 15 and is using up to 50% of my CPU.
In this version the problem is not solved.

Now cdmagent is using up to 80% of my CPU…

What I have observed is that cmdagent is hogging my system even though the Antivirus is paused…

Unless you are saying you have a identical problem to the OP

ie:- due to 50 to 100% cpu usage on cmdagent.exe when trying to start some programs, also the task bar freezes up, and also have everything disabled except Firewall set at Custom policy and AV set at Stateful.

If not could you please post a new Issue Report.

Thank you

Dennis

In my opinion it’s the same identical problem.

About 2 weeks from the last contact from support?? Sorry, but I won’t wait more… I’m uninstalling Comodo and trying out Microsoft Security Essentials.

Just discovered very interresting thing - solution???!

TRY TO DISABLE AV-DB AUTOUPDATE for the real time scanner !

It worked for me! Probable cause - cmdagent.exe (AV-protection process) seems to try to update each time it scans something in the background (it should not do that). That means it does it almost continuously, especially when loading or resuming the system from suspend. It causes system blocking with CPU continuous operation. That results in cfp.exe to do the checking/sendig/receiving packets (firewall process) - also CPU loading procedure. Something is not right as the two disturbs each other or sth.

Worth to mention that I do not use ‘cloud scanning’ - so it is not the case. :slight_smile:

Shirka, please do not double post!

You have posted this exact same reply in four different threads. This is not allowed.

The possible solution I provided is for a number of posts. I think it justified - to double posts. I hope Comodo values, that I possibly resolved the issue that was not resolved for years.

Will Comodo fight not to provide that knowledge to the users?

Double posting is not allowed regardless of the reason, as it is against Forum Policy. The policy exists to keep the forums a nice place to visit, and all users are expected to follow this policy.

I have almost the same issue. But with me it’s cmdagent.exe using all memory instead of cpu. It slows everything down to the point where I installed a new Windows on my other hard drive (now I know it’s cmdagent so goodbye COMODO firewall)
The screenshot is taken while doing nothing, just watching it grow and fall again.

[attachment deleted by admin]

Hello, dear Comodo! I have the same issue. In standby slowdowns my CPU to 50% (2core’s CPU).
ver of CIS - 5.9…