CIS child / option widows appear to hang for quite some time (30 -200sec)

1: CIS version:7.0.317799.4142
2: OS version: W7 HomePremium SP1
3: What you did: any non main app window takes forever almost locks if you clicl apply or OK or Cancel. like even just adding a exclude folder or a trusted exe
4: What you actually saw: they freeze until some hidden job is done for 30 to 180 sec at times. the main window is responsive but the child / option window remains frozen until some time.
5: What you expected to happen or see: apply and be at least the same speed the old version was , like less than 30 seconds for a simple change.
6: If possible attach a screenshot illustrating the GUI problem NA

Just seems painfully slow and remove and re-installation made no diff. I only use COMODO no other tools .

Processor: AMD A6-3410MX APU Quad Core +1 video card
OS: W7 (6.1) HPE SP1 RAM: 6144 MB DDR3
Card 1 :dis HD6470M 1024MB | Card 0 :int HD6520G 512MB

Please try reinstalling by following the advice I give in this topic and let me know if that is able to solve this issue.


Was reinstalling able to solve this issue?

Okay, I am going to assume that reinstalling was able to solve this issue. I will therefore move this to Resolved.

Prime_8, if reinstalling was not able to fix this please let me know and I will move this back to the main bug reporting board for processing.


sorry bad week at work , i will try the step when i get home . I cannot connect personal computers to the WiFi at work or i would do it now .

No problem. :wink:

If reinstalling by following those methods is not able to solve this let me know and we can look into it further.


yep looks like a clean fesh install solve dteh speed issue in HUGE way .

sadly i lost all my firwall settings and exluded files and folders LOL

I code apps/tools/games and i have to now hadn re add all my exclusions . LOL

but now that CIS is fast again that should not be too hard .

Thanks :-TU

well i wish the add trusted files in a folder took extensions
& the trusted files list could select files by folder & extension so i can remove the 4k html files the folder add put it . LOL

For future reference, before reinstalling you can export your configuration. Then, after reinstalling you can import it into the new installation. Sorry, I should have mentioned that before. However, do note that sometimes importing an old configuration could cause problems if the configuration was part of what caused the issue.

Let me know if you have any questions.


yeah , it woudl have been cool , but i was not taking any chances .

it’s so much faster , in fact whole boot times with new build are faster .

the thread you pointed too is very thorough . :-TU

I’m happy to hear everything is working much better. I can tell you that whenever there is a major update I tend to do a clean reinstall of CIS, including getting rid of rules. I find that if I do this the chances of experiencing problems is much less.


well i was just using the Unrecognized file dialog to add a installer to trusted , and the windows has hung .

in facts its still sitting at “please Wait” animated gif thing now . Kill switch cant even kill the window !

I have to say I sort of miss the old version rite now . lol

installing jMonkeyEngine SDK 3.0 from is what triggerd it .

im finding this version of CIS , interferes with the development environments i use .

I with i could set total ignore folders , where it would simply ig nore all from a folder , or like the old “learn” mode . so it can lear the all im doing is normal.

i have use Comodo fore ages , it would be a shame if it keeps messing with / or tripping over my work.

temp disable sand box is hand but it only finds the dang files when it wakes up . lol

i fear the data base tool or something is too slow / not very multi-thread stable or something ?
nany how i’ll see if i can kill the hung window & restart .

nuts cant edit .

but just got it closed , i had to use windows task manager to brows to teh process , and kill it there .

that worked. it was doing nothing 1% cpu , but using 1.135GB of ram , and climbing .

only 150 files in the list .
seems fine now i killed it .
will try to install jME again with sandbox off. LOL .
any how i suppose it just due to teh shear volume of files that change.

I’m sorry to hear that the issue has returned. I will now move this back to the main bug reporting board for processing.

Please edit your first post so that it is in the format provided here. Just copy and paste the format, then replace the question marks with your responses.

Let me know if you have any questions.

Thank you.

Please edit your first post so that it is in the format I linked to. Without that there is not enough information for me to forward this to the devs.

Let me know if you have any questions.


PM reminder sent.

since i forced closed the window it has been fine since .

and i found a way to remove files on batch from the trusted list .

simply rename the issue folder , and the click purge in CIS , and wait for a time relative to the number of files.

the put that folder’s name back .

i’ll call this " careful how many files are in folder on folder add ". ~~ solved .

I’m happy to hear that this is now working correctly. I will therefore move this report to Resolved.

However, if the issue returns please be sure to let me know.