CIS Causing Legitimate Apps To Crash [M817]

  1. CIS is crashing legitimate apps
  2. CIS is giving me error when trying to save it on disk (see screenshot).
  3. COMODO Internet Security 7.0.308911.4080
  4. Windows 8.1 x64
  5. Proactive configuration with following changes (see attachment).
  6. Clean install.
  7. Nope.
  8. Pretty much random. I experienced it with MPC HC, Photo Gallery, Razer Synapse, 7zip Theme Manager.
  9. Just tried 7zip Theme Manager. It was sandboxed, so I put it to exception. Next time it ran fine, but when I tried to change file icons, Resourcer started started crashing when trying to replace them with new icons. Several icons were left unchanged. So I tried to do it again. This time it just froze. Third time it started crashing again.
  10. This is the biggest issue so far. And I’m sure this is caused by CIS, because when I got rid of it, everything returned to normal.

P.S.: This issue inherited v7 from v6.

A video showing this issue can be downloaded from here:
https://dl.dropboxusercontent.com/u/35443524/Steam%20crashing.mp4
(FYI, both Steam and Razor started working after second restart)

Removing the trillian plugin solves this issue. The plugin can be downloaded and installed from here:

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

If you change the default directory you can save the diagnostics file. In proactive mode even CIS itself cannot save to it’s own directory.

I had this issue as well as indicated by my other bug report about this diagnostics report issue, however I tried to save it to several different folders but it just wouldn’t work…

OK I used the documents library, and it saved. In the CIS program directory it did not.

Replicable in Win 7, admin account, Uac off.

But thanks for telling us Sanya and please report this as a separate bug, making clear that for you choosing a different directory did not help. You might also want to check what happens if you use fast user switching to change users to a normal user and then change back again to admin and run diagnostics. I get strange pulsing circular pointer effect. Wierd!

I have… But for me it’s intermittent… https://forums.comodo.com/bug-reports-beta-corner-cis/diagnostics-report-fails-to-save-the-report-t101514.0.html

I’ve rebooted and now I find different behavior so I agree.

OK, just tried to give it another shot. After restart MPC HC started crashing again. In USER32.dll with error code 0xc000041d.

Notification windows freezed, so i had to shut it down. As a result, CIS reported that it blocked access to it’s memory.
Is this normal?

[attachment deleted by admin]

Okay, to entirely rule out the possibility that this is caused by some sort of configuration issue, please reinstall CIS by following the advice I give in this post. Then, without changing any settings, see if the apps are able to work correctly. If they are then slowly change your configuration and try to figure out after which change the crashes start occurring.

Thanks.

That tutorial is useless for me, because I have Windows 8.1 x64. :smiley:

The advice still holds. Of the two tools referenced one of them does work with Windows 8.1. Try reinstalling after running that removal tool in Safe Mode.

Thanks.

Revo Uninstaller doesn’t work on 64-bit system and Uninstaller Tool for CIS doesn’t work in Windows 8.

I am confused. The link for the removal tool here (direct download) should work for Windows 8. Are you having trouble with this removal tool?

No, but in your tutorial you wrote that it doesn’t work.

Perhaps the wording in my tutorial was confusing. The direct download link I provided in my previous reply does work fine with Windows 8.1. I apologize for the confusion.

Was reinstalling able to fix this issue?

If not then I will let you know that the devs have not been able to reproduce this issue. Thus, if reinstalling does not fix this, they have requested that I ask you to create a video showing the issue you are experiencing. Is that possible?

Thank you.

Video: https://dl.dropboxusercontent.com/u/35443524/Steam%20crashing.mp4

Thank you. I have now added the download link to the first post and alerted the devs that it is available. If any additional information is required either myself or the devs will contact you.

Thank you.