CIS causing black screen after few minutes

I’ve been using Comodo for so many years wthout much problem on my Win7 64-bit.
Last night I got an update prompt (version 10 I think) and I accepted. The update took quite a while but eventually finished.

Upon re-starting my computer, CIS started asking for programs permissions which I already permitted, as if it forgot previous settings.
After a few minutes the screen turned black and the PC was unresponsive.
This kept happening every single time I rebooted: my screen went black after a 1 minute or 2, and my PC became unresponsive, expect for a hard reset.

I’ve not had that happen to me before. The only change to my PC was updating CIS.
I launched into safe mode and let the PC run for a while, no issues.
I rebooted into normal mode and shut down CIS, which stopped the black screen.

So, I tried uninstalling CIS via Control Panel > Programs and Features > Uninstall feature, but I was unable to since I got an error while uninstalling:
“Could not delete key \Software\Comodo\CIS\Installer. Verify that you have sufficient access to that key, or contact your support personnel.”
I am the admin on this PC, so I am not sure about insufficient access.
I tried pressing “Retry” which did not help, and “Cancel” aborts the process. I have not tried pressing “Ignore” for fear of leaving leftovers behind.

I would like to get my PC and CIS into working order, as it was before this update.
Any idea what could be causing this problem?
How can I uninstall CIS fully so that I may try a fresh install?

Any advice please?

Did you try to disable HIPS and Auto-Containment?

I am not sure what was causing the issue post v10 update, but shutting CIS stopped the black screen from occuring.
I could not afford to do any troubleshooting or checking which module was faulty, because I was afraid the black screen would happen at any moment and I would have to reboot the PC.

I did manage to uninstall CIS by clicking on “ignore” when I encountered the error above. I restarted the PC and CIS was gone.
Then, I did some registry cleaning with CCleaner to remove some leftovers.

I redownloaded the latest v10 manually and reinstalled it. I did NOT get that black screen again.
I am still not sure what caused CIS to bug out, and I hope it does not happen again.

Afterwards, I spent a few hours with Customer Support using GeekBuddy, but they could not shed any light on the cause.
They did mention that there was a bug with v10 that had been fixed, but that bug did not cause a black screen.
Maybe it did on some systems or in some cases?

Something probably gets blocked due to unavailable/lost file rating. Perhaps it’s a good idea to launch a rating scan after the update as preventive measure.