CIS Causing 100% CPU Load and Overheating

The latest update of CIS causes my Dell Latitude C640 to immediately go to 100% CPU usage and run the system temperature to dangerously high levels (~88C).
My system is completely unusable in this condition.
Previous versions of CIS did not do this.
I am running WinXP Home SP3 on an Intel P4 2GHz w/1G of RAM.
The version of CIS is CIS_Setup_3.13.125662.579_XP_Vista_x32.exe (this is the setup file name- I can’t use the system to run the “About” application.
When I uninstall CIS the system reverts to normal.
Using Windows Sysinternals Process Explorer I can see that cmdagent.exe is grabbing huge chunks of my processor time, enough to interfere with everything else that is going on.
I have been very happy with CIS in the past, so I’m hoping that you can tell me how to stop this or where to get the previous version to reinstall.
Thank you.

I should probably point out that your system should never overheat at 100% CPU load. If it’s a custom build, replace your cooler or fix your airflow.

If it’s a prebuilt, clean it or if it’s a laptop you might need a warranty (or it’s a design flaw and you’re SOL).

The comodo part I can’t help you with.

Since Comodo doesn’t seem very interested in fixing this, your best bet is going to be to install CIS without the AV module and install another free option such as Avira or Avast.

Same MartyD situation, cmdagent uses 100% CPU. No way i uninstall CIS_Setup_3.13.125662.579_XP_Vista_x32.exe, and install CIS4 beta and solved the problem.

It’s an old creaky laptop, has been disassembled many times (by me).
What scared me was that I had just disassembled/reassembled it to repair the PS/2 jack on the back upon which it had been dropped with a mouse plugged in. Punched the jack right into the laptop. Everytime I put the old guy back together I hold my breath that it’s all still going to work.
That’s when I noticed the 100% CPU usage and alarming temp rise. Eventually, I determined that the hardware was A-OK and it was CIS 3.x cmdagent.exe tieing up the CPU
So, hasta la vista, CIS…
Now I’m running Avast! AV and ZA firewall. All back to normal.
I did really like CIS, though, since the AV and firewall were integrated into the same package.
How do you like CIS4 beta?
I might still go back to that if it doesn’t cause this problem.
BTW- I also installed an older version of CIS3.x and got the same problem… I don’t know what to think about that, unless there some element of CIS still installed that now is forcing older versions to do the same thing.

You can install CIS without the AV module. You can do that and still use Avast!. I would definitely recommend CIS’s firewall over ZA.

Well, CIS4 beta seems to cause me the same problem, except this time it took me an hour to uninstall it.
Interestingly, I have CIS3, the version that started all the trouble, installed on a desktop of about the same vintage, with no problem.
So, CIS is entirely gone and I’m back to Avast! AV and ZA firewall.

That isn’t good news. I was hoping I’d be able to start using CAV again. :cry:

Again, you can install CIS without the AV component… Cmdagent.exe won’t task your CPU to 100% without the AV. Comodos firewall is superior to ZA’s.

I personally had to recently switch to Avira for my AV because CAV was killing my system. The 3.12 update of CIS started making my system unresponsive during updates due to the extremely inefficient disk I/O. Up until that point I had no problems whatsoever. Then the very recent .581 update started causing cmdagent.exe to monopolize my CPU during startup. That was the final nail in the coffin for CAV on my system.

I’m perfectly happy now running the firewall and D+ from CIS and AV from Avira.

@MartyD. What process was causing the high CPU usage?

It looked to me like it was cmdagent.exe in Windows SysInternals Process Explorer.
I also have an app called 'What’s Runing?" that showed cmdagent.exe using big chunks of processor time.
Understand, I was experiencing periods of 100% CPU usage that were lasting indefinitely, not jusy for short periods of time.
ALSO: I think I spoke too soon when I said the that desktop I had CIS installed on semed fine. It’s now acting the same way.

On a sidenote. The latest version of CIS is 3.13.blabla.581. Use the program updater (Miscellaneous → Check for updates) to update to the latest version if you already didn’t do that. It is not very likely that will change the behaviour.

In fact, this update caused the 100% CPU issue for me…

I am not suffering from locks ups that seem to have no reason but on my system with older hardware it tends to choke Explorer when opening a folder with lots of files like system 32 or my folder with software downloads (installers and archives are quite a challenge for AV’s; not just for Comodo; I have seen this also happen with AVG 8.x and 9.x).

I noticed that changing the AV from Stateful to on access makes things manageable. The CPU usage is high but doesn’t choke navigation in Explorer anymore.

It looks like stateful inspection may be playing a role. Who of you has set the AV to Stateful? Can you see what happens when you change the AV setting to On access?

The AV has caused this issue many times before and it seems to re-appear with updates once in a while. I will have to agree that the best solution is to use another AV. Keep using CIS for the firewall and D+ as these 2 modules are fantastic.


I believe there have only been 2 or 3 updates in the past year that weren’t pulled or had another rapid release to fix the previous release… I honestly believe Comodo is simply spreading themselves too thin. “Live” product fixes should always take precedence over the development of additional products. You always want to keep your existing users happy. An unhappy current user can cost you dozens of future users.

Yep. I hate to say it, but as much faith as I used to have in Comodo, (Happy user since version 3.4) their treatment of CAV has worn my patience too thin and forced me to finally install another AV. I have also recommended all the people I recommended CIS to, to do the same. I just got too tired of having to contact them and tell them they might want to hold off on updating for a while… :cry:

same problem for me!!!

use cis 3.13 build 581 and when update av cmdagent.exe hangs my system!

now use avira! but i want use comodo, please solve this bug!!!

PS: if i try to format win and reinstall i have same problem…


Please your attention. I have noticed there are at the moment two kind of performance problems with the AV 3.13. One “general” performance problem and one likely to be caused by faulty update around January 17-18.

For the faulty AV definition update I made a test case in which I want volunteers to participate. I tried this myself and it got rid off certain reported problems that seemed typical for this particular problem. For those who want to participate go to [Testcase]AV problems with XP after January 17 or 18.