CIS causes Winstep Nexus Docking app to hang [NBZ]

Good day, Dennis.

I suppose I just put too much information into my post in response to the suggestion that as much information as possible should be supplied. Since it appears that this is not the case for the FIRST post, I will gladly edit it so that it may be considered. I am therefore posting it here. If it would be preferable to simply start a new thread, please let me know and I will do that.

here is the edited version of my post:

TOPIC TITLE
CIS causes Winstep Nexus Docking app to hang

The bug/issue

  1. What you did: Nexus Docking app was installed and working properly until…
  2. What actually happened or you actually saw: Clicking on any icon in the dock causes the app to hang. It freezes. Clicking on any part of the screen causes the dock to appear white and after a few seconds windows reports that the app is not responding.
  3. What you expected to happen or see: I expected the correct program to open when I clicked on the dock icon.
  4. How you tried to fix it & what happened: I tried reinstalling Nexus and reported the issue to Winstep when that didn’t work.
  5. If its an application compatibility problem have you tried the application fixes here?: I have explored the application fixes without success. I have made sure that all of the Nexus files are trusted files as well as Comodo files including guard32.dll and guard34.dll.
  6. Details & exact version of any application (execpt CIS) involved with download link: The application concerned is Winstep Nexus Advanced Docking System downloaded from Welcome Winstep Nexus Dock users - CNET Download
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: The problem reoccurs each time I try to run the program.
  8. Any other information (eg your guess regarding the cause, with reasons): There appears to be some incompatibility between the Nexus application and the guard32.dll file. The Nexus program runs properly if I uninstall CIS and delete the guard32.dll file.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: none
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: none
  3. A CIS config report or file. attached
  4. Crash or freeze dump file:

Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: Nexus.exe
Application Version: 10.9.0.921
Application Timestamp: 4caf1c2e
Hang Signature: 9bec
Hang Type: 0
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 4105
Additional Hang Signature 1: 9bec22aa14b33e9681d6a1b5f52129b4
Additional Hang Signature 2: 6d44
Additional Hang Signature 3: 6d44285f3a5de7e5bb5905d69fc8bbdf
Additional Hang Signature 4: 9bec
Additional Hang Signature 5: 9bec22aa14b33e9681d6a1b5f52129b4
Additional Hang Signature 6: 6d44
Additional Hang Signature 7: 6d44285f3a5de7e5bb5905d69fc8bbdf

Crash Dump Analysis


Crash dump directory: C:\Windows\Minidump

Crash dumps are enabled on your computer.

On Mon 2/28/2011 11:31:00 AM GMT your computer crashed
crash dump file: C:\Windows\Minidump\Nexus (5).DMP
This was probably caused by the following module: guard32.sys (guard32!?Exported[at][at]YAXXZ+0x83F)
Bugcheck code: 0x0 (0x0, 0x0, 0x0, 0x0)
Error: CUSTOM_ERROR
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: guard32.sys .
Google query: guard32.sys CUSTOM_ERROR

Your set-up

  1. CIS version, 5.3.176757.1236 AV database version 7828 & configuration used: Internet Security
  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Yes, I updated after complete uninstall and cleaning of files and registry.
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): I don’t think so.
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode , Sandbox= Disabled, Firewall = Safe Miode , AV = Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: 7. Other security and utility software installed: Windows 7 Home Premium 6.1.7600 64 bit SP1 NOT installed yet UAC = Never Notify Account type = Administrator; No other security software is installed
  7. Virtual machine used (Please do NOT use Virtual box): none

[attachment deleted by admin]

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis

More info here if required

I have found a fix or at least a workaround!

Since I have the same Nexus and Comodo installed on my desktop PC, I decided to try to import the configuration from that computer to the laptop having the problem. The desktop configuration was for Proactive Security while the laptop was set for Internet Security. First I changed the laptop configuration to Proactive Security. Then I imported the config file from the desktop PC. After doing this, I rebooted but Nexus would still not work. I then proceeded to force a delete on reboot of guard32.dll which was in the c:\windows\sysWOW64 folder using Unlocker (freeware at Download Unlocker 1.9.2 for Windows - Filehippo.com). Rebooted and Nexus worked perfectly.

I am attaching the configuration file which I used to get it going.

Jay

[attachment deleted by admin]