CIS causes system crash transfring large files via ethernet on local netwrk 1412

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, assumed 100% reliably.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Start the computer
2: Create a large amount of traffic (eg. transfer large files from another machine via ethernet on local network)
One or two sentences explaining what actually happened:
The computer bluescreens after several minutes, several codes have been observed (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED, KMODE_EXCEPTION_NOT_HANDLED, SYSTEM_SERVICE_EXCEPTION)
One or two sentences explaining what you expected to happen:
The computer remains stable.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not a software compatibility problem.
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:, Firewall Security config.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Safe mode HIPS, Autosandbox disabled, Custom Ruleset firewall, Viruscope disabled.
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5 or CIS6?:
if so, have you tried a a a clean reinstall - if not please do?:
Not applicable.
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win8.1, 64-bit, Notify on changes (no dim), administrator, not a VM
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Microsoft Security Essentials b=None

[attachment deleted by admin]

Could please give me the dump file, this will help us to check what’s happening. Thank you very much

Hi CoolPro

Very sorry you are having this problem.

Hopefully there will be a file called Memory.dmp in your C:\Windows directory.

Please ZIP that up and upload it to a cloud provider - provides large amounts of free storage.

If you can do this I will forward this to format verified which will give you the best chance of a fix.

BTW how much data in how big files did you need to transfer to cause this?

I will leave here pending your response

Kind regards


Mouse, thanks for the reply. I have already sent some minidumps to Flykite. If those are not enough I can try to get you a kernel memory dump as you requested. Waiting for your word.

I don’t know exactly how much data. It took about five or so minutes at around 10 MB/s for the crash to occur, so… 3 GB about?

Hi CoolStoryBro

Unless you have been told differently for this particular problem, a minidump is not normally enough.

Also if you add the dump link this issue will get moved to format verified and tracked by the mods.

Do you know how to set up your computer to generate full dumps? If not I can help.

Kind regards


Thanks for the offer, but I do know. I’m uploading a kernel memory dump now, will that do?

I am sorry I know its a pain but it has to be a full or complete dump - if you zip it it should zip to 10-15% of original size. The less apps you have running the smaller it will be when zipped.

Kind regards


Sadly this means I will have to induce the crash again, which I currently haven’t got the time to do. I will report back as soon as it’s done, but it could be a few days.

That’s Ok Coolbro. We usually wait about a wekk for a response anyway.

Good luck


All right, here is a complete dump: MEGA

It was significantly harder to induce this crash because the frequency seems to decrease with page file size, but it is definitely the same kind of crash that happened earlier.

I have also experienced a lot of different STOP errors since updating to CIS v8. I have now disabled cmdguard.sys via registry and was able to uninstall CIS and the system seems stable again.
I am afraid I only have a few Kernel dumps of the different errors here.
Should I upload them (new topic because i am using Win7), or would they not help anyway?
The errors seem to have appeared in random modules and with random Error Codes. It seems like something corrupted kernel memory.

Have you sent the dump file to Flykite?

Even if you already have I will forward this bug to the devs. Also i modified the title to be more descriptive i hope you dont mind

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

I haven’t sent the dump to Flykite explicitly but in any case thanks for the forward. I should mention that this problem is not exclusive to transferring large files over the LAN as you have named it in the title; the system will happily crash during other network-intensive operations such as using the BitTorrent protocol as well.

If the devs need additional follow-ups from me, I should be available often enough. I would really like to see this problem fixed.

The devs have informed me that they cannot reproduce. They have asked for a video of reproduction (what you did before the blue screen)

Hi Coolstorybro,

As wasgij6 informed, it would be highly appreciated if you could send a video of reproduction for us to investigate.

Thank you


As it turns out, this was a driver issue all along. Microsoft pushed an update for the NIC driver a few days ago and the system has been rock solid since, so the firewall was probably simply triggering the old driver misbehaving.

That’s about it, nothing more to see here. The nearest mod may move this to resolved.

Thanks for letting us know. I will now close this in the tracker.