CIS causes full CPU usage (CIS v3.9.95478.509 VSDb v1214 Win32 XP SP3)

CIS version: 3.9.95478.509
VSDb version: 1214
CPU/OS: Win32 XP SP3 (admin account used)
Actively running security/utility products: CIS, CMF and Spybot S&D

Problem description:

When I have CIS installed, some other software on my computer runs at full CPU usage (50% on my Core2 Duo system) or becomes unresponsive. In particular, I have found the following issues:

  • Visual Studio 2008 cannot compile programs (cl.exe and at times mspdbserv.exe run at full CPU usage and never finish (see screenshot))
  • PellesC (a C programming IDE) cannot load its debugger (idespawn.exe and poide.exe together run at full CPU usage and never finish (see screenshot))
  • Java occasionally runs at full CPU usage

I know for certain that CIS is the issue, because when I uninstall it all the issues are gone. I have seen similar issues (particularly with Java) mentioned in relation to CMF on this forum, but I have already added all the relevant processes to the exclusions list to no avail (see screenshot of CMF exclusion list). What is strange is that even when I boot my computer in diagnostic mode (with only 16 processes running (and not CIS)), the issues are still there (see screenshot of processes).

This issue is probably not limited to the programs I have mentioned, so is it possible for the underlying issue to be properly resolved? Failing that, is there some way that I can exclude CIS from blocking/conflicting with these processes? I have already tried disabling AV, Firewall and D+ but it makes no difference. No settings have been changed - I just did a completely clean install of the latest CIS today.

If anyone has any thoughts, suggestions or ideas to fix this, I would greatly appreciate hearing them. This issue has caused me heaps of grief in the past (I could not even install VS2008 without first removing CIS).



[attachment deleted by admin]

Hi Matt,
From the screenshot’s you have attached, i see that you are using Comodo Memory Firewall which is been discontinued as a stand alone product, and now included in Comodo Internet Security Suite With updated technologies (New Memory Scanner). So i would request you to check after uninstalling comodo memory firewall and reinstall CIS 3.9 alone as a clean install.

Note:- While Installing CIS, It’s Recommended To Disable Spybot S&D

Hi napsterz,

Thanks for the quick response and good idea. I tried your suggestion but unfortunately it made no difference. I removed CMF as well as i-Vault and LaunchPad, all of which have been discontinued, and reinstalled CIS with Spybot disabled. Before CIS was installed, I could use VS2008 and the PellesC debugger with no problems. After the installation was complete, they didn’t work anymore. Also, soon after the reinstall, Java began running at full CPU usage as well (see screenshot).

I really like the Comodo products, but if this cannot be resolved I will have no choice but to remove CIS because I need my other software to function fully.



[attachment deleted by admin]

Hi all,

Has anyone got any further suggestions on this one? I’ve looked quite a bit for an ‘exclusion’ list similar to what CMF had. The only one that seems to exist is for AV exclusions, which makes no difference in this case (I tried it anyway). Much as I don’t want to, I will be forced to move back to Norton Internet Security if no solution or work around can be found.

BTW, the Visual Studio Just in Time Debugger (vsjitdebugger.exe) also has this problem (runs at full CPU usage when CIS is installed).

Does anyone else have this problem?

Thanks heaps,


Hi Matt,
First Of All, Sorry For The Delay. Alright. Comming To The Issue, i Would Request You To Check After Disabling D+ Permanently

[attachment deleted by admin]

disabling defense+ helped, now any clues what to do with enabled defense+? ;p got that problem for 6months and just few days ago when i uninstalled CIS i realized the problem was due to CIS

Check Enabling D+ After Adding The Application To The Image Execution Control Exclusion List And Update The Results

still the same, also tried several other things, like adding to My Own Safe Files in defense+, and sliders in Image Execution Control, and Defense+ to Disabled. no effect.


@Matt_Hellyer. Can you show us the Defense + logs from around the time you are running the mentioned programs?

oh, my bad i thought i posted something before here. I’m not Matt_Hellyer, but i got similar problem. with stacsv.exe - IDT Audio something, it uses 50% (100% one core) on my Core2Duo processor. stacsv.exe is starting with windows and i can only see it in my Task Manager when i will open it with Administrator rights(UAC prompt). I’ve got this problem for something like 6months. I’ve got CIS and only CIS (disabled Windows Defender, used BOClean before it was included in the newest release)

Well i don’t know where i can find Defense+ logs, besides View Defense+ Events in which i got (attachment)

To sum up.
When i check Deactivate the Defense+ permanently the problem dissapears

When it’s unchecked(Defense+ enabled):
tried turning on and off every option including adding to My Own Safe Files and Image Execution Control Exclusions, sliders, Monitor Settings(checking and unchecking all) problem exists(i was trying those things one by one, restarting my computer all the time)

[attachment deleted by admin]

Try updating to the latest version of the audio driver. Also consider disabling the program from starting up with Windows when you don’t need it.

it is the newest version, and yes when i try to disable it i get crappy sound

any other clues? ;p


If you have VIsta please try uninstalling these IDT PC Audio drivers from add/remove progrms in control panel and reboot.

Maybe Windows will provide better drivers that the one that were previously installed.

This issue may not be strictly related to CIS whenever deactivating Defense+ may apparently mitigate it.

yeah, tried that - uninstalling driver in hope windows driver will be better, and it’s not.
This issue may not be strictly related to CIS but uninstalling CIS resolves my problem! so is it related or is not? :wink:

Most posts I’ve often read are like this whereas in many cases no information was actually provided to confirm if uninstalling something else resolves the problem too.

As for IDT PC Audio drivers they pose similar issues even if CIS was not installed as well (Could it be they cause the same issue when installed along with many other applications as well?)… :wink:

I got the impression that many posters are under the assumption that CIS is the only cause whereas many relevant information are often neglected. :-\

Apparently many ought to be fine by simply posting that uninstalling CIS alone workaround their issue. :-X

A good news is: Dell and Samsung users have the same problem, just search in web. Maybe we should contact the manufacturer of IDT-Audio-Device instead of waiting for HP?