CIS Causes Excessive Drive Activity At Win 7 Startup

First, hi everyone. I’ve used Comodo Firewall for a long time. Lately I’ve noticed that upon starting my rig that once I get to the desktop my hard drive was being accessed excessively for a long time (4-5 minutes). opening apps during this period were sluggish and the overall responsiveness of the os lacking. To trouble shoot I used msconfig to stop all startup apps and through the process of elimination found that CIS was the cause. For now I have un-installed it and gone back to the windows firewall.

I don’t like this solution because of how easy CIS is to configure and maintain. Anyone have an idea what may be causing this?

Q9550, 500 gig Seagate 7200.11 drive, 4 gig memory

Sorry to hear you were having bad experience with CIS.

Just for clarification. What OS are you on? Where you using firewall only or firewall with av?

Hi Eric. OS is Windows 7, it’s in the subject. Windows 7 Professional, if that’s what you meant. Just using the firewall not AV. AV is Avast.

I haven’t had a bad experience at all. I actually have had great experiences with Comodo products. The firewall I think is the easiest, most intuitive firewall I’ve ever used. But this long duration before the OS settles down every time I boot/reboot was starting to get old so I un-installed until I could figure out how to stop it.

So I presume this is not normal? I never noticed it before, just over the last couple months. I just recently got around to troubleshooting it. I thought i might be related to an update or something or a known problem. Sounds like it’s not. I’ll download the newest version and re-install this weekend and see if it comes back.

I should disable the windows firewall…right? Does this leave me vulnerable via IPv6?

Are you on Win 7 32 or 64 bits? Was cfp.exe or cmdagent causing the havoc?

Win 7 and Vista have a wonderfully extended performance monitor that can help here. To start it go to Task Manager → Performance → start Resource monitor (at the bottom of the tab).

Try cross referencing cpu usage and disk usage to the activity of the offending Comodo file. I have seen cmdagent being dragged along by some Windows process that was running. I saw that one time in the past while running a test version of Comodo.

Concerning IPv6 and CIS (not supported as of yet) read this wonderful tutorial by Toggie.

64 bit.

I did try to check the task manager. But I was looking for excessive usage, not any usage. I wasn’t really able to glean anything from that. I do think it was cmdagent that was using the cpu, but only at 4% or so (going from memory here). I just know that after I uninstalled cis the problem stopped. Let me re-install tonight and see if the problem comes back then I’ll update this thread.

Thanks for the link.

Keep us posted on it.

Please use Resource Monitor. That may give the information we need. Task Manager is only a very basic monitoring tool by comparison.

Well I downloaded and installed CIS again. This time I also installed AV and dumped Avast. Problem seems to be gone. Nothing else has changed so I’m at a loss as to why I was experiencing the issue. It was consistent though everytime I rebooted. In any case, the reinstall seems to have fixed it. Just one more unsolvable mystery.

If it acts up again, I’ll try to do a better job of checking it with the Res Mon and post back. Thanks for responding and the tips on how to troubleshoot.

Glad it got solved even though it is unclear what was going on…:smiley: