CIS Causes Delayed Write Failed messages with certain Applications [NBZ]

The bug/issue
1. What you did: ran Adagio(accounting software) on machine with CIS installed
2. What actually happened or you actually saw: Windows Delayed Write Failed errors (discribed below via event viewer) during login to Adagio and while performing various operations
3. What you expected to happen or see: no errors
4. How you tried to fix it & what happened: exclude associated network drive from within CIS, disable Defense+/Sandbox, exit comodo via System Tray, error still comes up
5. If its an application compatibility problem have you tried the application fixes?: Softrak contacted, cites network issues and/or security software interfering with application, no patches availiable
6. Details (exact version) of any application involved with download link: Softrak Adagio
7. Whether you can make the problem happen again, and if so exact steps to make it happen: Launch Adagio, attempt login, error presents itself immediately
8. Any other information (eg your guess regarding the cause, with reasons):
I have a computer here that runs accounting software that makes reads/writes to a network drive. Upon installing CIS, disabling Defense+/Sandbox, mapping the network drive and adding its contents to the ‘Safe Files’ list, i get a load of ‘Dalayed Write Failed’ messages from Windows when the program is trying to execute operations to the network drive. Event viewer logs the following errors:

Event ID: 50
Type: Warning
Source: MRxSmb
{Delayed Write Failed} Windows was unable to save all the data for the file \Device\LanmanRedirector. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

Event ID: 26
Type: Information
Source: Application Popup
Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file \SOFTRAK\DATA\FOLDER\APGLOB.NEP. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

Disabling or exiting CIS does not solve the issue. Also tried adding the network location and the running application (in this case Adagio) to the safe list, still errors crop up.

no errors from within Comodo, all errors are caused by Comodo when trying to run this program

Uninstalling CIS solved the issue.

Your set-up
1. CIS version, AV database version & configuration used: 5.0.163652.1142; DB 6580
2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?: yes
3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?: no, new install
4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ) no major changes other then disabling certain components
5. Defense+ and Sandbox OR Firewall security level: disabled, only AV running
6. OS version, service pack, no of bits, UAC setting, & account type: Windows XP SP3, 3GB memory, 80GB hard drive, admin account was being used
7. Other security and utility software running: ISA 2004
8. Virtual machine used (Please do NOT use Virtual box): none

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation



Thank you for the bug report. Much appreciated.

Moving to format verified.


Please try the application fixes here and post the results.

Many thanks