CIS blocks Windows Media Center with Ceton InfiniTV PCIe

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Install Ceton InfiniTV with cablecard, install drivers, set up Window Media Center. I am able to watch live TV and record shows.
    b: Then install CIS and reboot after updates and initial scan. InfiniTV is at IP address, with DHCP address assigned on PC of The Ceton Diagnostic will run, but Windows Media Center can’t watch or record TV, even when the firewall is disabled. is in the trusted IP zone. Windows Media Center displays: "Service is unavailable. There is currently no TV signal detected for this channel. The channel may be temporarily off the air. Try again later.
  • If not obvious, what U expected to happen:
    I expect to be able to watch live TV and record shows which I was able to do before installing CIS and also after uninstalling CIS.
  • If a software compatibility problem have U tried the conflict FAQ?:
    I tried to search for “conflict FAQ” on both the forums and the main Comodo site, but I could not find the FAQ.
  • Any software except CIS/OS involved? If so - name, & exact version:
    Windows 7 Media Center, Ceton InfiniTV drivers
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I also tried allowing for the system process, but that did not help. The Windows Media Center Receiver Service executable is C:\Windows\ehome\ehRecvr.exe and the Ceton Driver is at “C:\Program Files\Ceton\Ceton InfiniTV\InfiniTVSvc.exe”. I added those applications to the firewall and set them as allowed applications. Windows Media Center still can’t show live TV or record, even with the firewall set to disabled. I had to uninstall CIS. Partway through the uninstallation process, the TV tuner kicked back on and I was getting both video and audio. I am able to watch and record TV with PrivateFirewall and Avira free antivirus.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:
CIS 6.3 Build 2976, Proactive

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All, HIPS=off, BBlocker=Partially limited, Firewall=Off, AV=cloud is off
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Yes. I tried it twice.
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    Yes. It does not help.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7, SP1, 64bit, UAC=off, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS: a=None b=PrivateFirewall and Avira free antivirus

Hello. For future reference, use the format provided in this post:;msg651613#msg651613
Just copy and paste the code. Then put your responses after the colons.

I tried to interpret your report into the new format, but was not able to answer every question. Please edit your first post to make sure that all important details are included and correct. Once you have done that also attach the diagnostics report and the process list.

Thank you.

PM reminder sent.

Thank you for updating your report. Now that I understand the issue better I’m briefly checking with the other Mods to see if anyone has thoughts for a way to get this working without waiting for a fix. I’ll keep you informed and if nobody has an idea for how to fix it I will forward this to the devs.

However, in order to forward this to the devs please attach the diagnostics report to your first post. Also attach a process list. Both are required in order for me to forward this to the devs as they contain information which is crucial for identifying the problem, and therefore allowing it to be fixed.


Can you show a screenshot of your Global Rules?

As it appears that this issue may be fixable I will temporarily move this to the HELP section. There it will be able to attract maximum attention.

If, even after trying all suggestions, it becomes obvious that the problem cannot be fixed and is a bug, I will move this back and continue processing.

Thank you.

Sorry it took me so long to get this together. Since I am completely unable to use CIS on this computer with a Ceton InfiniTV tuner card under Windows Media Center, I needed a sufficiently large time interval to do a complete image backup, uninstall the other firewall and antivirus, then reinstall CIS. Note that even when the firewall and Defense+ are disabled, I still can’t use media center. As soon as I finish this post, I will have to uninstall CIS again to be able to use Windows Media Center. You weren’t specific on how to obtain the process list, so I just used the tasklist command line program, and also took 2 screenshots from the task manager.

[attachment deleted by admin]

Thank you for going several extra miles for this. I have two more questions to help further narrow down what’s going on. Can you give the executables belonging to CITV the Trusted Application policy? Does that fix it or does the problem persist?

If the problem persists. Can you try to disable the Inspect packet filter driver? How to do this? Look at the image where to be and disable Comodo Internet Security Firewall driver? Does this “fix it” or does the problem persist?

I did have problems connecting Media center to Xbox, the only thing I can suggest is changing your bottom Global rule to log then check the firewall logs after each attempt to connect.

This was how I fixed it.