CIS blocks file sharing from Win7 to Linux

Hi,
I am out of ideas why CIS is still blocking my file sharing from Windows 7 to a Linux system (debian jessie).
I am using the latest CIS version.

The configuration looks like this:
The linux system is running as virtual machine hosted on the same Windows 7 system. The network adapter is set to bridged.
Both system are in the same network (192.168.0.0/24) and receive their IP by DHCP. IPv6 is been disabled.
The linux system mounts the filesystem using cifs and gets is config from fstab:
//192.168.0.55/temp /mnt/temp cifs credentials=/root/.smbc,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

I defined a global rule that any port is allowed when source and destination address are within this network zone.
To my understanding this rule should be enough to access my shared folder - unfortunately not :confused: the mount fails with a error message:
mount error(115): Operation now in progress
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

However when I deactivate the firewall the mount succeeds.

I already tried some firewall global rule configurations, with no success:

  • allow everything from a source with specific mac address
  • allow ports 135-139,445 (TCP or UDP) from any source to any source
  • allow everything within the loopback network zone

Any hints or advices are appreciated.Thanks.

What version of Windows are you using on the host and which VM software are you using for the guest VM. Also in addition to global rules you need to create the same allow In rules for System and svchost.exe under application rules. Your best bet is to create a network zone that contains the IPv4 address and subnet mask, then use that zone to create the rules for global and the Windows System Applications application rule such as the attached screenshots.

[attachment deleted by admin]

Hi -
I am using Windows 7 professional x64 with SP1 and automatic updates enabled.
The VMware software should be one of the latest versions, it is VMware Workstation 12 Player Version: 12.1.1 build-3770994.
My Linux VM is Debian 8.2 with build 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) i686 GNU/Linux

I haven’t had the application rule, so I added it but it is still not working :cry:

I’ll add screenshots of my current configuration.

[attachment deleted by admin]

Everything looks right so I don’t know why its not working. However I have one final suggestion, make a new application firewall rule for ‘Windows Operating System’ when you go to add a new rule click browse > running process and select Windows Operating System and for the ruleset select Allowed application.