CIS blocks BitTorrent Sync, even when it's allowed

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Every time without fail. Ergo, it never works.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Start BitTorrent Sync.
    b: CIS warns about internet access. Click “Allow”, with the box to remember checked.
    c: Observe that BTSync traffic is still blocked, and nothing is synced (after setting BTSync up, of course)
  • If not obvious, what U expected to happen: BTSync would be able to sync data.
  • If a software compatibility problem have U tried the conflict FAQ?: Couldn’t find anything relevant to this case.
  • Any software except CIS/OS involved? If so - name, & exact version: BTSync, latest version. IE 10.0.9200.16721. Nothing else is relevant.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: I tried different manual allow rules for BTSync, none worked. Also, CIS will still block this traffic when the firewall is shutdown/disabled entirely. Also, BitTorrent is aware of this issue, but says it’s Comodo’s bug to fix.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:6.3.297838.2953

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:AV: stateful, Auto-sandbox: limited, HIPS: Clean PC Mode, Firewall: Safe Mode
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a CIS 5?: Nope, was a clean install.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7 SP1 x64 UAC on, admin account
  • Other security/s’box software a) currently installed b) installed since OS: a= Malwarebytes (free version, on-demand only) b= Used to use Avast, but I fully uninstalled that and switched to CAV (for the integration with the firewall).

[attachment deleted by admin]

What are your Global Rules? Can you post a screenshot of them?

TransientResponse, please post the screenshot of the global rules.

PM sent.

I apologize for the delay. I had some things to attend to in my Linux partition yesterday.

I’ve attached the global rules. I created one (BITSYNC) in an attempt to get BTSync running.
It is as follows:

Allow UDP in or out from any source address or destination address from any source port to destination port 55532 (based on what little information I could find about BTSync’s ports).

I know the program does not work whether this rule is there or not.

[attachment deleted by admin]

I feel like this is something which can be solved by creating the rules a certain way.

However, I am not an expert in this particular field. Thus, as it is currently not getting much attention, I will move this to the HELP section of the forum.

This will give you a chance to get feedback which may be able to allow you to get BitTorrent working. However, if it becomes apparent that this is certainly not fixable, please let me know and I can move this back to the bug reporting board.

Thank you.

Hopefully in the HELP section it’ll get more attention. But I’m not sure creating the rules a certain way will alleviate the issue-- as I noted in my report, CIS blocks BitTorrent Sync traffic even when the firewall is disabled. The BitTorrent support people told me that the only way to get it working again is to completely uninstall CIS, or at least the firewall portion thereof.

Also, I want to make it clear that this issue pertains to BitTorrent Sync, not the regular old BitTorrent P2P file sharing. Regular BitTorrent works fine.

Additionally, if anyone here thinks it’ll help I have two BTSync log files: one from my windows machine, with its traffic killed by CIS, and another from my linux machine, which works fine. Both cover a period of about 15 minutes.

Have you tried running the stealth port wizard? if you havent try running it and selecting to alert incoming connections.

you might also try setting the firewall alert frequency to very high.

I’ve got the stealth ports alerts turned on now, but so far not a peep with regards to BTSync. The firewall traffic meter shows it has a little traffic trickling through (a few bytes per second, off and on) but BTSync itself shows no connected devices. I even removed and re-added the sync folder, nothing. No alerts.

My Nexus 7 (the current other end of the sync) also shows no devices, but that app has very limited information on what’s going on with the sync.

Did you try setting the alert frequency to very high

Yes, alert frequency very high. Not a peep about BTSync (yet, anyway).

I just installed BTSynch and it open two ports one TCP and one UDP with the same port number on my router.

Try changing the Global Rule for BTSynch to allow for incoming TCP and UDP traffic and give BTSynch the ALlowed Application policy in Application Rules of the firewall.

In Global rules change the block rule at the bottom to block and log.

Does this change the situation for you?

BTSync was already an allowed application in the Application Rules.

And I no longer have the block IP global rule-- after the attempt to use the stealth ports wizard and high alert frequency, I now have these global rules (attached). The BTSYNC rule is now set to allow TCP or UDP in from and to any address and any port. I also have it set to log when fired.

Still no significant traffic from BTSync yet.

[attachment deleted by admin]

Development: I removed and re-added the folder from BTSync, with the same secret, and now it works.

I’m guessing the loss of the block all IP rule may have fixed it, but it’s strange the last time I re-added the folder (yesterday) didn’t get it working.

Thanks to everyone for all the help. It’s good to know that BitTorrent was wrong about Sync’s incompatibility with CIS.