CIS Blocking Driver Downloads

I have a Windows Vista 64-bit System and have had some problems downloading drivers. I have Comodo Internet Security. Specifically my printer driver, and drives E:, F:, G:, and H:. I did a system restore back to a date in November and when completed I received a popup that there was a bug in my Comodo software. I uninstalled my Comodo Software and downloaded again. This updated all my Portable Drivers except my Canon Printer driver which is still giving me trouble. I tried to add Canon as a Trusted site, but that is not helping. I keep getting a popup indicating “Access Denied”.

Any suggestions? Thanks.

Can you show a screenshot of the pop up of the Access Denied event?

Here is a screen print of the message I am getting. It refers to the original error I was getting for my E:, F:, G:, and H:, drive, but now I am getting it for my printer - the message at the top references my Canon printer. I resolved the error popup for my drives, but have been unable to resolve the error for my printer.


[attachment deleted by admin]

Can you take a look at Defense + → Advanced -->Computer Security Policy → now select services.exe → Access right → push the button behind Protected Registry Keys → look in the Blocked Registry Keys tab to see if there are any keys blocked. If so delete them or the one you think may be applicable.

The reason for this is when installing a driver you will be alerted by services.exe to allow services to install. When blocking that you could end up with this situation I think.

Thanks. I’ll try that.

Thanks for your instructions. No problem following them. Only 1 Blocked Registry Key. I removed it although it was not familiar to me and started up my printer . . . same error message (attached).

Any other suggestions?

[attachment deleted by admin]

To see if CIS is involved can you post a screenshot of the D+ logs? They can be found under Defense + → Common Tasks → View Defense + Alerts.

Also try disabling D+ permanently. That is to see if D+ interferes or not. Go to Defense + → Advanced → Defense + Settings → tick “Deactivate the Defense + permanently (requires a system restart)”. Now reboot and try again.

Another possibility could be that during the installation process Win 7 alerted you to decide you to install a driver. May be you denied? When you also set to remember that answer then may be this could happen.

Tips for making screenshots. Use alt+print screen button to copy the picture of the active window. When editing the image in Pain or or similar programs use the Crop function to shrink the canvas size to the size of the image.

Attached is the Defense + Log for the past week. Also, I don’t have Windows 7, I have Vista Home Premium for 64-bit.

I tried your second suggestion . . . deactivated the Defense +, rebooted and when I turned on my printer, I received a popup indicating that the “J:” drive needed to be updated (new popup then previously received). I did that and it updated successfully. Reset Defense + to Safe and rebooted PC. Started up my printer and NO PROMPT TO UPDATE DRIVER!! Thanks so much. Hopefully this does not prevent other updates.

Thanks again.

[attachment deleted by admin]

Glad it got solved. Now I see the log I see where my initial assumption was wrong. I thought it was about a services.exe related error. But it is actually related to rundll32.exe. Please make sure there are no blocked application for rundll32.exe. You can use the same procedure as I described in the above.

Thanks I will. This has been a great experience using this forum. Thanks for all your help.