CIS/BB and portable software.

I don’t entirely understand why, but there are some portable programs I use that just can’t run unless I disable the BB. As far as I can tell, it’s portable apps created by ThinApp and Cameyo that have this problem.

What happens is, I run the initial exe which then tries to create other files in relative paths such as %AppData% and so on. But the BB kicks in and blocks the process. So I go into Unrecognised Files and send the exe to Trusted Files, but when I try to run it again then the same thing happens.

It doesn’t matter how many times I tell CIS that it’s a trusted file, it just won’t allow me to run it unless I disable BB completely which I’d rather not have to do.

I’m guessing, it’s probably something to do with the fact the portable app is trying to create new files each time it is run but I’m not certain.

Has anybody else come across this issue?

I have tried quite a lot of portable apps from site but no probs here.

But I haven’t tried portable apps from the publisher you have mentioned so dont know about them.

Hi thanks for the feedback. Yes I use a lot of PAF software too and as you say there seems to be no issue with those.

Elsewhere on this forum I was reading comments by devs who find their programs continuously blocked because every change and restart of their program results in the exe having a different hash signature, so I’m wondering if something like this happens with the portable apps that seem to upset CIS.

What happens with, for example, Cameyo portable software, is that you just have the one file, an exe. When you run it, it creates virtualised appdata and reg entries and so on, which when you close the app can be retained or wiped as you please. So I’m wondering if it’s this creation of virtualised components that makes CIS think they are different files every time, leading to the BB kicking in and blocking them.

Fwiw, the problem also persists if I add the program’s folder to the Trusted list.