CIS AV won't/can't update

This is a bug that was reported as long ago as 3.5 but appears to have been corrected for some/most people but I have one XP PC that still requires this workaround.

I think you will find that if you run Diagnostics it will try to reset the Service setting back to the original setting.

As for whether this is a safe setting, that is a question for the Devs.

Have been a bit reluctant to pursue this as a bug as I have problems with the video card on that PC so I’m always working semi-blind on that PC.

I would welcome an escalation of the bug by yourself as others who have posted may be suffering from the same.


Roba. Did you copy your settings of 3.5 to 3.8?

Well I’ve tried everything suggested on this thread so far and nothing seems to work.

Tried since last post…

  1. Change the Helper service logon account - no change
  2. Install BETA - no change
  3. Change the Helper service logon account for the BETA version - no change

Some things different on my system that may have an influence???
I have 2 ethernet ports.
ICS is enabled.
Running XP Home SP3 (even though CIS only seems to say it’s compatible with SP2)
I have no password set for my user login. (Or admin login but you have to boot in safe mode to get to it anyway for XP Home)

I have no idea whether any of these thing makes a difference but there you have it.


For my part, XP Home Edition SP3, CIS 3.8 was a fresh install after uninstalling 3.5. The Configuration was imported from an XP Professional System running 3.8 and not suffering from the same problem.

I have since uninstalled 3.8 and installed 3.9 494 Beta. Still no updating unless I use the workaround.


Unfortunately not even the workaround works for me.

Is there any way to manually update the Virus definition file like you can in othe AV applications?

Sorry for late reply.

First I tried it with copied settings, but when updates weren’t working, I did several clean installs of both 3.8 and 3.9 BETA. I checked my registry between installations and I am pretty sure the settings were gone.

+1 Thats what we need offline update :-TU many topics are on issue updates not working for many people on 3.5 version 3.8 version also on 3.9 version so provided offline update can solve all these problems for user,
Dev. please look into our request.
Thanks :-TU

Well I’ve tried everything now, still can’t get AV signature to update.

I think I have worked out how to manually get the new signature file though…

Have a look here for the latest database version:

Then paste the following url into your browser replacing #### with the database version

and hey presto, it downloads… now to work out how to apply it…

Ronny gives a clue how to do that in his post here
And now to try it… will keep you posted.

Results... dunno? The 'About' screen still says I'm using 1122 even though I downloaded and replaced bases.cav with the 1153 version.

Still says “The virus database has been updated on Never Updated
Even after reboot.
I am using CIS 3.9.75651.498 RC2 BETA. Maybe there’s a problem there? 3.8 bases.cav on CIS 3.9
Could that cause a problem?

Next step is to try doing it again but this time in safe mode… although I had no trouble replacing the files after exiting CIS.

Now I tried downloading and installing ‘Wireshark’ as suggested in this thread to try and diagnose my av database update problem.

When I checked for program updates in the miscellaneous category there was a flurry of activity. (This has always worked, but it doesn’t update the virus database.)

When I tried ANY method to update the virus database there was NOTHING! No activity whatsoever.
It never even sent a single packet on any interface (it checked them all).

Does that help to narrow down where the problem might be?

Hello? Is there anybody out there? Just nod if you can hear me.
Do I need to start a new thread? I apologize to the original poster if I hijacked their thread. It seems everyone else has been able to get it going though.
I must have uninstalled > regcleaned > reinstalled a dozen times now.

I wonder what percentage of people abandon COMODO after this long trying without success?

URL to download the Virus signature database for 3.9(BETA/RC) is


3.9 latest beta version solved virus signature update problem for me, for those who facing problem updating virus signature database can try new 3.9 beta too :a0

I tried that, it doesn’t seem to work. Instead of the file starting to download, all I get is “404 Not Found”

Oops!! I’m sorry… It Seems we can’t download the complete bases for beta unlike CIS 3.8…

Perhaps, you may try the following…
1.Disable the real time scanner and Automatic AV database updates under Antivirus → Scanner settings.
2.Go to C:\Program files\Comodo\Comodo Internet Security\Scanners and rename bases.cav to OLD_bases.cav
3.Run ‘Diagnostics’ under ‘miscellaneous’ section of CIS.
4.Restart the system
5.Try updating the AV signature database manually.


Those signature updates have been disabled until the public release of CIS 3.9

That only addresses the ‘off-topic’ question. Nothing seems to have been done to address the issue that some people cannot update their AV by normal means. It is certainly not addressed by either the Beta or RC versions of 3.9 and I very much doubt it will be by the General Release.

If you read the earlier posts, some cannot update at all, even after a ‘clean’ install and others require the workaround of changing the Logon Account for the Comodo Helper Service.

This issue appears to have been resolved for Vista users around the end of December but still remains for some XP users.


I GOT IT GOING!!! ^^ :cry: ^^

I tried (many times) to change the ‘Comodo Internet Security Helper Service’ logon account as suggested here. It never worked.
If I changed it to my logon ID and password it never started on reboot. If I tried to manually start it I got an error message saying the service couldn’t start.

So I looked at the sytem logs in the event viewer. There were Service Control Manager errors for every time I tried to start the Comodo Internet Security Helper Service. Error 7038…

The cmdAgent service was unable to log on as .\UserName with the currently configured password due to the following error: Logon failure: user account restriction. Possible reasons are blank passwords not allowed,

And that was the problem. I didn’t have a password set at all for the user. So I set a password for the user, changed the ‘Comodo Internet Security Helper Service’ logon details to suit and started the service. Service actually started this time. Tried updating the AV database and hey presto, it worked.

The only problem is now I have to enter the user password every time I start my computer (which I prefer not to have to do). But I think I know a way around that…

Glad to hear that but it doesn’t alter the fact that it is only a workaround.
(Running Diagnostics will change the Configuration back)

The problem still needs to be addressed.


You’re absolutely right Peroulades, the problem still needs to be addressed.

Hopefully the trouble I had and the reason behind it will give a clue to those trying to fix this problem (someone is trying to fix it aren’t they?).

I guess I can’t demand too much though. What do you expect for free!

Has anyone raised a proper bug report or Support Ticket?
Or has everyone assumed, like I did, that someone must have done it by now.

It would be nice to monitor the progress of the solution to this problem.


I haven’t because, as mentioned in an earlier post, my video card is kaput on that PC so any displays I could offer in support of a solution would be unintelligible.

Please go ahead. I’d be pleased to help in trying any suggestions that are offered.


Try the new v3.9. Get it here: .

Edit: You need to update to 3.9 because you won’t get anymore AV updates for 3.8. This is because of a change in the AV update format.