CIS AV won't/can't update

I am using CIS .477 and the AV simply doesn’t want to update. In the update window, the progress bar races to 30% complete and then stops. After a min or two, it says there was an error in updating the database, please check your internet connection. This has been going on for the past two days already.

I am using Vista SP1, all updates done. Just did a clean install of CIS after a format. All other internet activities as per normal. Had a look in the forums and see one or two others with similar problem. I followed advice given to them by checking registry settings etc., but no joy. All previous versions of CIS updated witout any problems. Makes me think might be a bug?

I only changed two settings in CIS. Set all ports to stealth and in D+ Image Execution Control to “normal.” Have tried updating by changing these settings back to default, but no difference.

Anybody have any suggestions please?

Same here. What’s up with this?

Me too.
Even if I temporarily disable our hardware firewall, it still fails.

At least make a manual update possible - a weekly downloadable update or something.

I have tried the new 3.9 Beta and same result. Everything works fine, but the AV can’t/won’t update. I notice there are other posts with similar issues, but as of yet, there doesn’t seem to be any real solution to this problem. Also, and please forgive me if I interpret this incorrectly, it seems that this particular issue is not being taken that seriously by Comodo staff. (For instance, not even a single comment has been made on my post.)

There are a number of us that can’t use CIS properly and it seems we are alone without any support. Can’t anybody from Comodo give some sort of idea as to why this is happening? Any suggestions as to how we can fix this issue? What about standalone AV database updates like Symantec offers?

I really want to continue using Comodo, but how can I if the AV database won’t update? I have been using Comodo products since 2006 and this problem first occurred with CIS .477. Makes me think it’s not on my side?

Can someone from Comodo please give this issue the attention it deserves. Thanks.

Did you import your 3.8 profile by any incident? Check out this note:;msg268374#msg268374 .

hi, thanks for replying.

no imports etc, i did a format and then a clean CIS 3.9 beta install. same went for CIS .477. using Vista SP1 x32. only other security software installed is mbam free. windows defender & firewall both disabled.

i have used the same setup for the past two years and never had any problems updating comodo products. i used CIS prior to .477 as well, and it updated fine without any problems.

There is a newer version of 3.9 beta (491). Wanna give it a try?

thanks for that! installed new beta .491 without any problems, however it tells me the AV database is up to date, so i can’t test it… lol

will see how it goes over the next few days.


I can’t update either. I did clean install of yesterday’s beta, it did not work, today CIS Beta updated itself to the latest beta version and it still doesn’t work. :frowning: I checked my registry keys and they are ok.

result :slight_smile: CIS beta .491 has fixed the AV update problem for me. it’s working again. whatever Comodo has changed in this version, hope they keep it.

Make sure the registry value of ‘Update path’ and ‘Update URL’ (at right pane) under
‘HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0\AV\Settings’ is as follows

CIS 3.8:
Update path must have the value : av/updates38
Update URL must have :

Update path must have the value : av/beta39
Update URL must have :

Also, Verify this for
‘HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\1\AV\Settings’
‘HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\2\AV\Settings’ and etc


i have it all but nothing seems to be working
and also i formated my hard drive (for other reasons) and so i did clean install of comodo and update is still not working. I have 3.8 version
hope new stable version will come out soon

I’m having the same problem. Checked through all the suggestion in this post (except beta) and nothing helps.

Could you try this and see if it helps:

  1. Boot to safemode
  2. Go to C:\Program Files\COMODO\COMODO Internet Security\scanners
  3. Delete or rename bases.cav
  4. Go to C:\Program Files\COMODO\COMODO Internet Security\repair
  5. Copy bases.cav from C:\Program Files\COMODO\COMODO Internet Security\repair to C:\Program Files\COMODO\COMODO Internet Security\scanners
  6. Reboot
  7. Open CIS and update virus defs

Keep us posted

Ok. I did exactly as you said. Then I did a file compare of the old and repair files and they were identical.
Then I rebooted. Still no good.

For about 1/4sec a window titled “Virus Database Update (5%)” is up saying…
Please wait while virus database is being updated.
This might take a few minutes…

Then another window takes it’s place titled “Failed…” saying
Failed to update the virus database.
Please check your internet conection and try again later.

If I reinstall CIS then update the program, it updates the virus database.
Then if I try to update the Virus Database it fails as described above.

The version I’m installing is “CIS_Setup_3.8.64263.468_XP_Vista_x32.exe”
The version it updates to is 3.8.65951.477

Are you willing to try a clean install of 477? The procedure is as follows (it also contains saving your configuration):

Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run Comodo System Cleaner to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

Now you should be good to go and give the install a try.

OK, I did exactly as you specified.
Pretty much none of the files/folders you said to delete existed after uninstalling.

The Comodo System Cleaner is very cool though. Computer seems to boot faster since running it.

I tried updating before restoring my settings and after. Exactly the same result. Failed to update the virus database.

It isn’t just giving me the wrong message is it? I would expect it to say “Already up to date” if I try to update the virus database immediately after installing the latest version of the app.
Virus defense summary says it was updated 15mins ago (when I installed it).
But after a day or so it doesn’t change. Then it reports virus database out of date.
Then windows security centre starts whingeing that it isn’t up to date. That’s why I came here.


I checked my registry keys as hiddenstar suggested, they are ok. I also tried the base.cav thing (both files were identical), but the result is still same.

I am using 3.9.74199.494.

BTW, when I run SmartSniff to see what is CIS doing when I try to update, there is absolutely nothing logged. CIS does not attempt to connect any remote address when I click update database link.

I will try reinstall once again, this time with System Cleaner, I will post here if it worked.

May I ask you to try updating the Comodo Internet Security Helper Service?

Logon Tab for the Service should currently show Local System Account and Allow service to interact with Desktop

Set This Account with your Logon ID and Password (+Confirm) and then reboot as it will ask you to do.

Now see if the AV update works.

Report back if it works but restore the settings to Local System Account if not (You will need another reboot).

Hello Peroulades,

thanks for your suggestion - it worked! I had to grant Log on as a service right to my user first, but then CIS Helper service started under my user and virus database update link started to work.

Can I keep these settings? Also, do you have any idea why it doesn’t work with standard settings?

Thanks for you help again.