CIS AV Scanning in XP Safe Mode

Hi Guys…

Today I tried to run an AV scan in XP Safe Mode. It wouldnt have a bar of it.

Firstly D+ had a problem starting and then after a short while when I attempted to run an AV scan I was presented with the error message depicted in the second screenie (attached).

Is there an issue with running a CIS AV scan in Safe Mode?

Apologies if this has been covered elsewhere - I DID search prior to posting this :stuck_out_tongue:


Toshiba Portege M300
1 GHz Centrino, 1.25 GB RAM
WIN XP SP2 fully patched.

CIS: Current

[attachment deleted by admin]

Evening “tsec”

My name is Jacob Kilgore,
I’m one of the Moderators here at Comodo Forums
I would like to try to solve your Issue as Quick as Possible

Defense+ Does not load in Safe Mode, Since its driver is not fully loaded in “Safe Mode”

I believe, I’m not sure, but AV’s Driver is not loaded either,

I’ll await others to answer.

  • Jacob Kilgore
    C-O-M-O-D-O Forum Moderator

Thanks Jacob :slight_smile:

Anyone else care to confirm Jacob’s point regarding the AV driver(s) under XP’s Safe Mode?



I can confirm that the antivirus doesn’t work in safe mode on my systems (XP and Vista 32bit).

Yes, same here. I don’t believe any av that uses services will run in safe mode.

Fine - thanks guys.

I wonder if this can / will be a feature in the future?



I think it could be a very useful feature for removing some nasty files that are blocked in normal mode.

True. Dr. Web CureIt and Kaspersky AVK run fine in safe mode and offer a second opinion and cleaning options.


Does this need to be formalised in the wishlist section of the forum, or can we relax, knowing that Melih has read this thread? :slight_smile:

Hi Jacob,
After looking at your post, I tried to do some research with this issue and I would like to share the results of it in this forum,
as you mentioned, i thought that it’s because of the drivers doesn’t load in Safe Mode, the AV is not running. So i enabled the Comodo services in minimal boot so that i can start the services in Safe Mode. Even after that I am not able to scan. However I remeber that once i did a scan in safe mode at the time Of installation. So I uninstalled CIS and reinstalled from Safe Mode With Networking and started the scan process when its prompted at the time of installation. When the scanning started, I noticed that none of the COMODO Services Or Kernel Mode Drivers were loaded. So, If I am able to scan during the time of installation from Safe Mode, Then it should also run after the installation. However it’s not running. I’ve attached the screenshot for your reference.

[attachment deleted by admin]

Interesting point.(:NRD) Maybe the scan runs from the temp setup files?