CIS AV, MS Word 2000 and USB-drive = doc deleted on save


When editing and trying to save MS Word 2000 doc located on USB-drive, error message “Word cannot complete the save due to a file permission error. ***” is displayed. Doc is deleted and there is a temp-file in Word which I have to save if I don’t want to lose the document.

In effect I cannot use Word on docs located in USB-drive.

Problem can be resolved by disabling Comodo AV, but that is not a very good solution…

I’ve searched Your forums and it seems this has been a known issue for some time now and indeed it has been known issue with some other AV engines as well. Other AV engines have settings/special procedures to deal with this.

Is there a solution for this issue, if not is there going to be a solution in very near future for this issue?

Using latest CIS (3.12…), Word 2000 sp3 (+all hotfixes), Windows xp sp3.


Hello m0ka,

Welcome to the forums, I’m unable to replicate this in Office 2007 with a save as 97-2003.doc
Are you using the AV in OnAccess or statefull mode ?

Thank You!

I can edit and save docs only when AV is disabled, other modes deletes doc.

I think it really is Word version rather than doc version. Altough I’ve read this can occur with newer Word versions as well.

I can only replicate this behavior if i have an Active scan running, like for example if i start a context-menu scan and the file resides in that folder structure i do get a save error.

However if i stop the scan (pause won’t help) then there is no problem, are you perhaps scanning in the background ? Does a “My computer” scan finish normally on your system ?

I’ve also read it is possible to overcome this issue by converting NTFS instead of FAT/FAT32. In my case this is not possible, I need my USB flash drives in FAT32.

No, there is no scan running. I tried scanning my USB flash drive and it went ok, did not try “My computer” scan though. Will do that next.

Earlier today I saw another user reminding the devs that this particular problem with Word 2000 and saving on a FAT partition is still not solved. I can’t find the topic at the moment…

There is a mention in this post
issue (no.2 in the post) been fixed, asked more info. Still waiting…

Clearly this issue is relevant to those using Word (2000) and USB flash drives, hopefully Comodo will look into this and we’ll get this fixed as soon as possible!

Not just word 2000 and not just FAT32/USB drives. The combo of Word 2007 and a NetWare file system will also produce this under CIS V3.12.

Bummer :frowning:

You also can’t save a document on 2007 if you are also running a scan in the folder or subfolder where the document resides, it will cause a violation error.

This is already there from 3.5 beta bug report

Issue didn’t occur under CIS 3.10 or 3.11.

Sorry, is that a question or a fact on your side :wink:

Fact. Problem only re-occured after upgrade to 3.12. :’(