CIS & 'ASUS Data Security Manager' causes "Filename is not valid" error [M1483]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, anytime
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Install ‘ASUS Data Security Manager’. (attached : sample.zip)

One or two sentences explaining what actually happened:
Basically, you are able to download files from the Internet, but for example when you try to create a document or modify an existing one, when you try to save it anywhere on the computer you will get an error message. (attached: screenshot.zip)
One or two sentences explaining what you expected to happen:
Since you didn’t use any particular letters or symbols in the file name, you expected them to be saved.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
N/A
Any software except CIS/OS involved? If so - name, & exact version:
‘ASUS Data Security Manager’
Any other information, eg your guess at the cause, how you tried to fix it etc:
The only good solution is to uninstall ‘ASUS Data Security Manager’.

B. YOUR SETUP
Exact CIS version & configuration:
8.2.0.4591 but also a couple of previous versions, 8.X.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default
Have you made any other changes to the default config? (egs here.):
No
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Yes
if so, have you tried a a a clean reinstall - if not please do?:
Yes
Have you imported a config from a previous version of CIS:
No
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 64bit and Windows 7 64bit , UAC disabled and Administrator account.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a) N/A
b) N/A

SOLUTION: after many tries (and thanks to qmarius), it turned out the problem was a conflict between Comodo v8 and the “Asus data security manager” software that was bundled with my Asus laptop. After removing it everything was fine.

[attachment deleted by admin]

Can you give exact steps on how to reproduce this bug?

Well, actually there’s nothing in particular to do. The first time it happened, on Win 8.1, I had CIS installed as usual, as I had had it for a couple of years (I’ve been using Comodo Firewall since v2.4, but sometimes I like to try other security softwares) without any issues whatsoever. I remember I removed V7 and did a clean install of V8 without importing previous settings. Now, I’m not sure the issue came with the first release of V8 or with a later update since, back then, I didn’t realise CIS was the cause of it. Then, as I said, since I just couldn’t seem to find a solution (not even with the Windows System Restore function) I resetted my laptop to manufacturer setting, so basically it was almost like a Win 7 fresh install (with all the Asus bundled softwares, of course). I just removed the trial of Norton antivirus, if I remember correctly (or McAfee… but I don’t think it’s related to this) and a few bunch of other trial games and stuff and installed CIS. Then I tried to create a .doc file, gave it a normal name (like “Test.doc”) and clicked “Save”. Result: “Filename not valid”. Same if I try to save a PDF from, like, Foxit Reader. I deactivated all of Comodo protections but still the problem was there. Then I removed CIS and everything was back as usual.
The other day I thought of trying CIS again. Maybe with the new update it would have worked normally. So, I removed Bitdefender Ultimate (I had installed it for free using a 100 days promo code), rebooted, installed CIS, rebooted and the issue was back again. Now I removed CIS and installed Online Armor Free and Avast Free and the computer works just fine. I’m still on Win 7 64 bit.
Hope I’ve explained myself clearly. If you need more informations of anything, just ask :wink:

Hi colmoti,

Please attach a system summary. (run > msinfo32 > save)

Thanks.

Sure. Here it is :slight_smile:

[attachment deleted by admin]

  1. Please attach a diagnostics report.
    ( main user interface > question mark (?) > support > diagnostics )

  2. Try to change your system locale to English. Does the issue persist?
    Windows help & learning

  3. Make sure that you’ve ran the removal utility properly.
    Comodo Forum

Thanks.

Ok, so: I removed all my security softwares, rebooted, downloaded the Avast Uninstaller and the CIS Removal Tool, rebooted in safe mode, run both of them, rebooted normally, installed the latest CIS, rebooted, changed System Locale to English, rebooted. Unfortunately the issue is still there and, ironically enough, it does not allow me to save the diagnostic report. If I try to save it in the C: partition, I get the usual error; if I choose D: it says “file esauriti” (I cannot find the exact translation but it’s something like “no more files”).

I found another guy with the same problem. He wrote about it on the 15th of December, coincidently enough when I brought back my laptop to its manufacturer settings and he also solved it by removing Comodo Firewall. Here’s the link to the discussion, in case you need it (it’s in Italian):
http://www.pc-facile.com/forum/viewtopic.php?t=103494

Someone there hints to try CHKDSK and SFC/SCANNOW and now that I read this it came to my mind I also tried them with no results.

  1. Please post exact error message(s) in native language and translations where possible. Optionally, you should post screenshots.
  2. It’s not clear whether you’ve tested mentioned issue with version <8.2.0.4508>. Could you please clarify?
  3. If possible, could you please mention the version where you had no related issue?
  4. Could you please check under “Safe Mode with Networking” if you’re experiencing same issue?
    (note: having CIS installed but not running)
    Advanced startup options (including safe mode) - Microsoft Support
  5. Please mention if there is anything unusual regarding CPU, Disk, Memory activity? Optionally, try to kill processes (eg ‘cavwp.exe’) and check if the issue persists?
  6. Please attach a list of installed programs.
    Windows - Get a List of all Installed Programs (and Updates) | PeteNetLive

Thanks.

  1. I attached the screenshots of both messages (photos taken with my cell phone, since I couldn’t save the actual images on the PC) with the translations. I’ve found out the “Filename not valid” error shows up only if I try to save a file on the desktop, while the “Out of file” one kicks in all other occasions. I can, however, download files from the Internet (.exe and others), but I cannot save web pages.
  2. I’m running v8.2.0.4508 and the issue is there.
  3. I guess it began with the second release of v8, since looking at the release dates, v.8.0.0.4344 was released on December 11th, back when I first noticed the issue.
  4. In “Safe mode with networking” with CIS installed everything works fine: I can save files.
  5. I’m not noticing anything unusual, it’s all fine there. I tried killing cavwp.exe, cis.exe, cmdagent.exe with no results.
  6. Done. It made me export the list to the txt file with no problems.

[attachment deleted by admin]

Please try to uninstall ‘ASUS Data Security Manager’ and check if the issue persists.

Thank you.

And finally the miracle!! Yessss!! It works!!! Fantastic guys! Thank you all very much, especially qmarius! Sorry if I made you waste time :slight_smile:
Thank you again!

That’s great news. Please edit your report in order to highlight the conflict with ‘ASUS Data Security Manager’.

Thank you.

Perhaps I’m asking too much but could you test this issue with version <8.2.0.4591> ?

Thank you.

No problem :wink:
I’ve just reinstalled Data Security Manager and the issue is back, so it’s not solved with v.4591. Obviously, I unistalled the program and everything is just fine.

Thanks, colmoti. Please attach mentioned application.

Thanks again.

Here it is :slight_smile:

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Not a CIS bug from Comodo: The Dev states that “It happens as long as ASUS and another file system filter is installed (e.g. procmon). So it is a ASUS bug.”