CIS and msecure

I have mSecure 3.50 and Comodo CIS 6.2.282872.2847 with database version 16475 installed on my Windows XP pc and Windows 7 laptop. Recently, when I try to run mSecure on my pc I have started getting the following message: “mSecure for Windows has encountered a problem and needs to close. …” and asking me to send an Error Report to Microsoft. I have added the mSecure executable as a trusted file, but still it will not run unless I turn off CIS. On my laptop mSecure runs without any issues. Any help that could help me to resolve this would be appreciated.


Try adding mSecue to the exceptions of Detect shellcode injection.

Hi Eric

Thanks for the reply and link. I’ve added mSecure.exe to the exceptions, but it is a still no go.


What OS is your laptop using?

Please make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .

My Laptop has Windows 7. A couple of months ago I had to do a fresh install of Windows XP on my PC. Comodo CIS is the only security program that I’ve installed since that reinstall. After the reinstalll, until recently, mSecure ran without incident.

We may be looking at bug so I will continue asking questions to get a better understanding.

What version of CIS were you running after you reinstalled your pc? How did you update to the latest version of CIS?

Please check with Killswitch that msecure is not running sandboxed.

Ask away, I will do my best to answer.

I reinstalled windows on April 18. I would have installed CIS on either the 18th or possibly on thev19th. According to your website you released version 6.1.275152.2801 on April 17. I assume that would have been the version that I downloaded. CiS and Windows both did an update just prior to my realizing that mSecure would no longer run with CIS running. However, I do not know if the CIS update what just a database update or a program update, although I think it was the latter and i see that you released version 6.2.282872.2847 on June 19 which would be, I think, about when I started having an issue. All CIS program updates since the initial install have been done through the CIS.

Killswitch will not run on my PC. When I click on it, it gives the appearance that it is going to start and then it terminates without any messages. This is an issue that I’ve know about for a bit, but have ignored, It works finds on my laptop.

Did you have problems with msecure on your old Windows installation? Was there a version of CIS installed on that? If so which version.

Could you step by step disable the AV and Behaviour Blocker (Automatic Sandbox) and try to start msecure again?

I disabled the AV. It made no difference. I then turned Auto Sandbox off. It made no difference. I then tried turning off “Detect Installers and Show privilege elevation alerts” and WOOOOT, it fixed the problem! I’ve now re-enabled the AV and turned the Auto Sandbox back on. I assume that it is safe to leave the Detect Installer …" off? Also, for curiosity’s sake I checked my laptop, and it has “Detect installers …” enabled.

As for your other question, I did have mSecure and a version of CIS installed and they worked together without incident. However, I cannot tell you what version it was. Prior to the Windows reinstall I had been relying on my laptop for quite awhile.

Thank you very much for all the help.


My celebration was premature. Last night msecure was working after I disabled “Detect installers …”, but this morning I am back to the same situation. I have repeated the steps that took last night without success.

Can you post a screenshot of the Defense + logs. I want to see if there is something that gets logged that could help to shine a further light.

I attempted to run mSecure this morning and then generated this log:

[attachment deleted by admin]

It looks like this a bug, so if you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

I will check out the bug reporting procedure.

Thanks for all your efforts.