CIS 8.x & MacType service > 0x000021a

Ever since CIS 8.x I have compatibility issues. The installation goes smoothly. After the database has been updated and my system has been scanned I reboot as the normal procedure goes. When I try to login I receive: “The RPC server is unavailable”. A few seconds later I receive a bluescreen with error code 0x000021a. Sometimes I’m able to logon but it always ends with the same bluescreen/error code. This goes on forever and I am forced to restore my computer to an earlier state (CIS 7.x).

Now I have my computer reinstalled, the first thing I installed was Comodo 8.x. Everything seemed to run normal. I began adding all my other programs to my computer and found the conflicting software.

MacType ( Google Code Archive - Long-term storage for Google Code Project Hosting. ) has issues with the latest CIS. MacType can be run in 3 different ways: from the registry, as a service or manually. Usually I run MacType as a service. I tried to run MacType from the registry for the first time and it seemed to have solved the problem. However, I still would like to run MacType as a service.

The problem has occured on at least 2 computers. An AMD desktop computer and an Intel notebook. Both run Windows 8.1 x64. If it’s on MacType, the program hasn’t received any updates for a long time and I won’t be expecting an update soon. I hope Comodo can come up with a fix.

Please attach a system summary.

run > msinfo32 > save

Thanks for your reply. May I ask what information you need exactly? Hardware information? I don’t like to toss all my system information publicly on the internet.

  • if virtualization is supported
  • software environment, known conflicts
  • a diagnostics report might also help

I don’t think it has anything to do with virtualisation. On the AMD system it’s available/enabled, on the Intel machine it’s unavailable/disabled. Here are the requested files for the Intel notebook.

[attachment deleted by admin]

Also, please use the required format.


PM Sent

Since evdw87 has not provided all the required information for a bug report im going to move this to resolved. From the information given i cannot determine if this is a bug. compatibility issue, or setup issue. evdw87 feel free to add the information requested and we can continue processing this bug.