CIS 8 cannot be neither installed nor updated from CIS 7 [M1372]

A. THE BUG
Can you reproduce the problem & if so how reliably?:
I can reproduce the issue every time on two different systems: Win7x32 and Win7x64.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:

  1. I have downloaded latest version from the following link : http://download.comodo.com/cis/download/installs/4000/standalone/cispremium_installer.exe
    MD5 : a2ea26bb22947d7c23596dd18c09b579
  2. I have tried to install and selected the following options: D+/HIPS, Autosandbox/BBlocker, Firewall. (no AV module, no DNS change, no statistics sending)
  3. Installer asked to reboot. After reboot it continues to work, progress is at 99%, shortcut appears on the Desktop and then installer throws away an error (error 1603). The shortcut disappered. CIS is absent in the system - neither CIS 7 nor CIS 8 after reboot.

One or two sentences explaining what actually happened:
The installer throws away error 1603 & CIS is not present at all. Installation was not successful.

One or two sentences explaining what you expected to happen:
The installer should not give any error. Installation should be successful.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
N/A.

Any software except CIS/OS involved? If so - name, & exact version:
N/A.

Any other information, eg your guess at the cause, how you tried to fix it etc:
i. I have tried to clean the system using removal script from this forum as well as manual deleting everything I can find in registry using the string “comodo” - but when I tried to start installer it led to the same error (1603).

ii. I’ve ran the following commands with the same result :
Run > regsvr32 Atl.dll
Run > msiexec /unregister
Run > msiexec /regserver

iii. I’ve attached installer log & system summaries. Please check attachments.

B. YOUR SETUP
Exact CIS version & configuration:
See above.

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
N/A.

Have you made any other changes to the default config? (egs here.):
No.
Have you updated (without uninstall) from CIS 5 or CIS6?:
No.

Have you imported a config from a previous version of CIS:
No.

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Case 1. Windows 7 SP1 x64 Ultimate, UAC disabled, Administrator account, VM not used
Case 2. Windows 7 SP1 x32 Ultimate, UAC disabled, Administrator account, VM not used

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
None.

[attachment deleted by admin]

reference : discussion

Having the same problem, maybe

unfortunately it didn’t go well at all

installer failing with error 1603.

Executing op: RegSelfReg(File=cmdstat.dll,FileID=cmdstat.dll)
CustomAction +cmdstat.dll returned actual error code -2147024894 (note this may not be 100% accurate if translation happened inside sandbox)
Product: COMODO Internet Security Premium – Error 1904. Module C:\Program Files\COMODO\COMODO Internet Security\cmdstat.dll failed to register. HRESULT -2147024894. Contact your support personnel.

in the logs and a few more
To top it off, I can’t find CIS7 to install since all the downloads redirect me to 8 :frowning:

I’ve submitted a support ticket
Ticket ID #AAG-143-93690
Priority Urgent

Good day I can say that after I installed NEW windows 7 x64 Ultimate to my father and first program that I tried to install was Comodo Firewall Free last and I got error 1603 so definitely this is a bug.

I had a similar problem going from CIS7 to CIS8 on WIndows 8.1. I tried several different procedures (including the “official” one) and the installation of CIS8 did not go cleanly in any of them. The 1603 error was common.

In the end I did a clean reinstall of Windows 8.1, my drivers, and my applications and then installed CIS8. All went smoothly.

Hi gjf

I am very sorry you are having this problem, along with some others.

So I can forward this to QA, could you please confirm:

  1. That you have followed the procedure noted here exactly:
    Comodo Forum

If not please do try it

  1. What your original Window 7 config was prior to upgrade. Whether proactive or IS, and whether any other changes had been made from defaults, especially to HIPS settings. If you have kept an exported copy, please append it.

  2. Whether you are switching CIS config during the upgrade process (eg to proactive before the first reboot). This is something I got in the habit of doing and it can cause problems.

Kind regards

Mouse

As mouse1 has pointed it out- the removal tool has been modified to be more effective with latest version.
In order to process this issue we need to confirm whether the result is different or not.
If the result is the same, please consider a video. This will assure you that the issue will get confirmed.

I do understand your situation and I apologize for any misunderstanding.
Thank you for your patience. :slight_smile:

In order to process this issue we need to confirm whether the result is different or not.

installer fail and rolls back to no CIS.
I reboot, run script (COMODO Removal Tool 2014 - Mods version, options 1,2),
reboot,
run the script.
Reboot.

Try to install
Still the same error (1603 for overall intall and 1904 for the cmdstat dll/install fails)

What’s worse, the 7.0.latest
7.0.317799 fails to install with a 1603 after runing the script (before it installed but the fw failed after I uninstalled 8)

Anyhow, ran the script, rebooted,
ran the x64 MSI from somewhere in C:\programdata\Comodo Downloader, made it skip the cmdstat.dll registration error and everything appears ok .
Probably not the best idea, but better than not having either 7 or 8 installed at all.

If the result is the same, please consider a video. This will assure you that the issue will get confirmed.

mmm, is opening a support ticket with a cmdinstall.exe_*.log.7z attachment a better option? Surely the installer failing and installer log errors referring to specific dlls is confirmation enough from multiple people…

Thank you for your patience. :slight_smile:

=) we’re guessing Comodo support are all away due to the tgiving holiday. Unfortunate timing but not much we can do.

Thanks for the update, svyr.
From my understanding, QA will process tickets directly.
I’m not sure whether they provide frequent updates though. I always preferred the community way. I hope that answered your question.

It would be great if we could gather some system summaries (run > msinfo32 > save) from multiple users and the mentioned logs by svyr. (as a start)

Thanks again.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I think that the problem in the installer it self because I tried to install last version of Comodo Firewall Free on new and fresh Win 7 SP1 Ultimate x64 and I had the same 1603 problem, I can give a screenshot but it wouldn’t help, so the problem not only remainings of previous versions of comodo…

mouse1
As for your suggestion. And once again.

  1. As I understand you want to see my CIS 7 config, because I have no idea how to present you Windows 7 config. CIS 7 config is attached.

  2. Once again: I have tried not only update, but clean install after all cleaning procedures. Unfortunately somone edited my first post so it is not clear now. Both update and clean install leads to the same error.

[attachment deleted by admin]

Hi gjf

Very sorry again you are having this problem. Yes I did mean CIS 7 config, so thanks very much.

Thanks too for trying the new tool. I am sorry it did not help

Qmarius will take over from me from here, if that’s OK.

Kind regards

Mike

  1. If possible, could you attach a diagnostics report as well?
  2. I’ve repositioned information in order to comply with standard format. The title is very suggestive and it’s clear enough.

Thank you.

Upon further inspection, are you sure that you did not have any security software now or in the past?
I’m pretty sure that we are talking about some kind of conflict or at least a potential one.

Your configuration is quite complex as well. (eg high number of rules which translates in unknown applications)
I’d appreciate if we could get a common vector since multiple users signaled this issue.

Thanks.

The diagnostic log is attached. It is for x32, I can attach also x64 if it is necessary.
Yes, I can confirm there is no any other antivirus/HIPS/firewalls on the above mentioned systems.
The configuration is complex - sure, that’s why I use firewall and HIPS - and don’t use hosts rules, access restriction etc. You can ask the people who tried to install CIS8 on pure system from the zero (lordadrian for instance). Also - there was no any configuration when I tried to install CIS 8 after full cleaning - so I think it is not a source of problem.

Once again, guys: I can believe: me and some others are using some incompatible software, have improper installed Microsft Installer, trying to install CIS 8 in Halloween etc - OK, but: [[i]b]why CIS 7 installs without any problems in the same conditions and on the same systems[/b][/i]?

The logs.

[attachment deleted by admin]

Fair enough. I’m guessing it’s the same reason why we have conflicts with version 8_, and not version 7_. That doesn’t really tell a lot.
One could have conflicts with drivers. (eg some graphics drivers inject dlls in running processes)

If it happens at random the provided data should be enough. Else, the contrary.

Thanks.

I must say that all of you wouldn’t believe me now, so here is 2 screenshots:

  1. http://i.imgur.com/1kNB5GO.jpg
  2. http://i.imgur.com/oQcCIy0.jpg
    As you can see there is 8 minutes difference between screenshots but the result is clear. Installer of Comodo can’t work correctly because of “Language for non-Unicode Programs” if it is different from English in my case.
    I tried to install Comodo about 20 times without clearing registry so the problem for me it is not the evidence of previous installations, it is the non-Unicode language. I even tried to install when Unicode was Russian and installer language of Comodo was Russian and it didn’t work still was 1603.
    I must say that I am really tired after all time that I spend to find what is the problem of Comodo, please don’t make such bugs in future…

lordadrian
If it is true - great work, man! As for me - taking into account the number of bugs found in 8th version, I will wait for few next updates before installing.
And shame to dev team.