(CIS - Trusted Files List Not Saving Manually Created Entries

I have Windows 7 Pro 64-bit and CIS, Database Number 25508.

Whenever I try to manually add an entry to the Trusted Files List, Comodo doesn’t save the new entry. I can still do this in HIPS+ and the File Groups section under File Rating.

What could be causing this? Is it a bug? I have attached the diagnostic file should it be needed for troubleshooting. (log removed for now)

Also, if this is not in the correct forum, can the thread be moved to the correct place? Thanks.

Hi RightHere,
You are closing the advanced settings window using the OK button after adding the entry?


That’s correct. Is it possible an update to Comodo or maybe even a Windows Update could’ve broken something?

Hi RightHere,
Possibly an update broke something, I am more inclined to think there could be some database corruption.

Please note: My suggestion below will reset the trusted files and trusted vendors list.
These list will recreate and rebuild over time.

Have ‘cloud lookup’ enabled in the file rating settings.

  1. Boot into Windows safe mode.
  2. Delete the following files found in the ‘C:\ProgramData\Comodo\Firewall Pro’ folder.
  3. Restart the system.
  4. Run a rating scan.
  5. Try to manually add the required files and see if they stick.

Kind regards.

For the record, how do I run a ratings scan? I’m not sure where that setting is.

Edit: Nevermind, found it.

Scan and Clean your Computer-Comodo Help

I followed the steps you gave me and the problem is now fixed.

Thank you so much. You are a lifesaver. :slight_smile:

You are welcome, it is good to hear the issue is solved. :slight_smile: