CIS 7.xx to 8.xx update/upgrade won't work AND deletes Restore Points on attempt

Hi all,

I have been using Comodo for years and it is very much proved that it’s an outstanding quality
product… very loyal to it too… HOWEVER

My current CIS version/build is: 7.0.317799.4142. On attempt to update it to latest build (8.0.0.4337), it either
stopped the update process after 25% or after 99% @ times (with error msg’s) - usually " Comodo Installation Error
1603 ". I’ve tried the upgrade/update option it offered, not uninstalling it altogether to keep my firewall rules
and other settings.

OS: Windows 8.1 (update 1). 8GB Ram. 1TB HDD.

After about 4 hours of constant reboots and install, uninstall, retry and shifting between ver 7 & 8 setups, i did manage
to get my ver 7 back up… BUT… Now it won’t load up with windows automatically and upon
“upgrading” from ver 7 to 8, it deleted all my prior restore points (this is confirmed that the so
called update process procedure must have done it and not another program - on the first try). NO other install
was running in the background, although i also use other anti-spyware/antivirus programs which seems to never
conflict with CIS anyway (like malwarebytes).

I’ve even tried to manually remove the (left over) reg entries for the update, but no matter what i do, CIS entry will not
let me set, change, add, take ownership on that registry key.

I’m now going through the extreme option or trying to reset all registry and files permissions hoping it’ll work,
but…
if there is ANY better solution, it will be GREATLY appreciated.

Usually starting messing up with permission, on primary system leads to complete install for mess-ups… i can’t afford that on a (primary) system which also contain Visual Studio development section. – I probably should have installed it inside a VM to keep it seperate from primary system, but right now it’s besides the point anyway.

*** please note that Inside a virtual machine with win10, it went smoothly on install, no problems whatsoever.

Please Advise,

With Utmost Respect,

Kind Regards,
Me.

Does Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron help you here?

Thank you for your rapid response.

I will try that sometime this week and update here. I also made a few custom own task-schedule entries for loading it up. Except for somtimes freezing the system for a few, it loads up now. Once uninstalled and an attempt for installing the new version has been made, will update here as well.

Only thing i don’t get is, yes, upon install it creates a system restore, that’s fine and make sense… BUT… it DOES delete all other previous restore points :o, which basically can also be considered and an extra safety net.

Thank you again for your help and for pointing me in the right directions.

With Utmost Respect,

Kind Regards,
Me.

You tried installing CIS 7 and 8 various times and given that it will create a restore point upon installation that will start to eat away at other restore points. Is that what happened? I have had that happen when I had similar problems with another program.

Thank you again, so much, for the speedy reply…

I’ve been using Comodo for years. Truth be known, it’s the best I’ve found so far, slim chance I’ll ever replace it with another either
.
I’ve got enough space (and configured) to hold up as much as 10 different restore points, and I only had 2 upon installation. That’s why I had to wonder, why it added its own and killed the others in the process (all previous upgrades, always worked like a charm with no issues).

(As for the P2P mentioned in the thread, never had a problem, only thing I did, was to opt-in utorrent and such into the trusted files, never had as problem with it).

I have checked it with a dummy file, it does catch it into the quarantine… so I guess I’m trying to find if I should keep
it as is, even with my tweaks to load it via my own scheduled tasks i manually created, or, to use the tools on the link you gave me and then try the new version again (or just wait i guess till windows 10 RTM is out to do so).

With Utmost Respect,

Kind Regards,
Me.

You mentioned uninstallin/installing/retrying various times in 4 hour period. You would then end up with more than a couple of restore points for CIS alone. You may end up overwriting older restore points. How many restore points where there made for the various CIS installations?

Did you try installing v8 on top of v7? As a rule of thumb we always advice to do a clean install when with a big version number jump.

You mentioned you could not remove a registry key due to ownership problems? Is that for Legacy keys? To remove the socalled Legacy Keys, which are otherwise hard to remove, open Device Manager from the command prompt using the following two commands:
set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Set Device Manager to show hidden devices under menu option View. Then see if there are Comodo Internet Security related drivers left in non Plug and Play drivers. If so select the driver → click right → uninstall. Do this for all present CIS drivers. Do a reboot when it has been requested.

Hi again and thank you so much for your time and patience.

  1. followed your advice as to :
    set devmgr_show_nonpresent_devices=1
    start devmgmt.msc

Results: no drivers of comodo present/visible or otherwise.

  1. Yes, i have followed its offer to upgrade instead of clean install.

  2. Yes, i have to assume it was a legacy registry entry (although it didn’t have the usual visual format one will
    expect, it was shown up as a regular folder with its sub folders. — EVEN changing permission, trying to take over
    ownership, trying to disable permission enharitence first too, did not work (the ownership change however did succeed).

Currently, only one restore point, that is not Comodo related, but done by anothert software (RegRun virus scan). Making a fresh one now just in case.

Went one-by-one over the entire device manager tree… no Comodo related enteries and/or drivers exist in the
tree. (non Plug and Play drivers entry does not exist anyway).

** Currently, after adding manual entries in the task scheduler for comodo, aside of those that are already there, assigned with different conditions and triggers… at least it loads up so only question now, is if to leave it as is or go the extra mile and try to shoot it down with the tools you were so kind to direct me to, for immediate re-installation after.

Also, as per the length of the thread, regardless of if your final advice will be to leave it as is for now (not to fix what
ain’t broken) or to go ahead with uninstall/reinstall, i have no idea how to mark it as solved/close it.

With Utmost Respect,

Kind Regards,
Me.

We usually don’t close topics.

If you want to pick up on the topic feel free to post in it again.