CIS 7 firewall not allowing DC++ through no matter what

I recently installed DC++ and for the life of me can not get Comodo firewall to allow it to download or do searches in the program.
Comodo lets me run it and does seem to allow some connectivity because it will do a version check and will connect to hubs but it will not allow DC++ to connect to direct users. I know the ports are forwarded properly and the program is set up properly because when I disable the firewall it works. I have allowed the program and the executable in comodo as well as set up a custom rule for it yet it still will not work.
Any ideas would be great. Thanks.

Enabling File Sharing Applications like BitTorrent and Emule may be what you are looking for.

That looked very promising but I still couldn’t get it going. I tried both the emule way and the utorrent way.
Again, if I disable the firewall temporarily everything works fine. But of course don’t want to run p2p without the firewall. :frowning:

Thanks so much for the response though.
Any other ideas?

Could you give us a screenshot of the global rules as well as the application rules for the application? Also please specify which ports it need access to.

It seems like I have stumbled upon figuring it out.

I set up a specific rule for it using the utorrent as a template from this page: Enabling File Sharing Applications like BitTorrent and Emule,Comodo Firewall| Internet Security v6.2.
As I mentioned in previous post that did not (completely) do it.

Since then I went into the Stealth Port settings just as a last ditch effort, and clicked on the ‘Alert Incoming Connections’ and suddenly DC++ is being allowed through.

Odd since I never went into the Stealth Port part before, but beggars can’t be choosers!
Thanks all for the help.

The stealth port option defines global rules, most likely you had a global rule that blocked all incoming connections, by clicking to alert you for all incoming connections it removed this rule and since the application rule says to allow incoming traffic it is now allowed to do so.

Thanks for explaining. If it happens again for something else I know one place to check. I thought I had gone under global rules to see. Maybe I had and missed it.
Anyways thanks again, it was nice to get the help and get it solved.