CIS 6 running very slowly

I have got in to the habit of opening the GUI by right clicking the icon and then selecting what area I want to open from the widget

Icon - widget - almost instant

widget - main interface - 2 sec’s

widget - Advanced settings - 2 sec’s

etc etc

I wish I had that LOL! For me it’s 30 secs or no response at all the fastest is 10 secs. :slight_smile:

I wish I had that LOL! For me it's 30 secs or no response at all the fastest is 10 secs.

That’s a big difference ???
I have been playing around with Exploit Shield and Zemana free and notice no slow down/lag when either of these have been installed
I suspect a bug report is needed…

Please try reinstalling CIS by following the advice I give in this post. If reinstalling it in this way does not solve your problem (and you are sure it’s not possible that it’s leftover remnants from other former security products interfeering) then please create a bug report for this. However, make sure you try reinstalling first.

Thanks.

Your guide on this is what I do each time anyway. Nothing to do with leftovers I know a thing or two about PC’s. And Radaghast also pointed out that it’s most def a bug. So nobody done it? A bug report for this? Or do I need to add one anyway? But thank you for the advice.

Unfortunately, that makes little difference. If I:

  1. Select open the Syetem tray Icon (instant response)
  2. Select Show widget (instance response)
  3. Select Firewall settings (First time 10 to 15 seconds. Subsequent 2 to 3 seconds)

I appreciate the response Chiron but this is not the cause of the problem.

Yes, please create a bug report for this. I don’t think one has been filed yet. Also, make sure to mention how you reinstalled as this helps to rule out remnants as being the cause.

Thanks.

Here’s a possible lead. I decided to re-image my main system today and with my images I typically don’t include things like third-party drivers, as they tend to change more often than I need to re-image. After imaging, I was please to find the UI quite responsive, not quite as snappy as 5.x but still acceptable. I then added the latest ATI drivers for my card, rebooted and I’m back to a horribly unresponsive UI.

What I need to do now is see if it was just a one off and also try some different driver versions…

@radaghast - I have found on my system with an Nvidia on-board graphics chip that with the most recent driver installed about every 5th start that the GUI is slow. I thought it just to be a Driver problem with Nvidia !

When the GUI is slow I change the screen resolution then change it back again and everything works fine ???

I had not done a bug report as wasn’t able to pin it down to either the Driver and / or CIS?

try to add the gpu drivers in exclusion of AV and D+

Thanks Valentin but I only us the firewall, everything else is disabled.

Update.

I’ve tried the ATI 12.10 and 12.11 Beta, I’m now using 12.6 (legacy) which seems the best, at least for CIS, so far.

What ATI chipset are you using?

I am noticing that you are using 12.6 Legacy driver which is basically for chips with number lower than 5000. I can imagine when using a legacy chip with drivers not written for it that may cause strange effects.

I am running a legacy ATI onboard chip (4200) and I have never tried later drivers than 12.6 Legacy as its the latest official driver. Starting CIS from the tray takes 2s max. Starting modules from the UI happens in half a second or less.

I’m just playing around with different drivers/cards at the moment. My main card, currently usurped by my daughter, is a 7870 and I tested that with 12.8, 12.10 and 12.11 Beta and none of them were terribly good with CIS.

I’m currently using a 4850 and so far I’ve tried 12.4, 12.6 (windows 8 legacy) and a 12.10 modded driver. Of the three, the 12.6 renders the UI reasonably quickly. The 12.4 drivers are by far the worst.

Not to sure if it would help narrow down the cause or not. :-
Is the CPU being hammered during the delay?
If yes, what process is doing the hammering?

The only processes that ‘spike’ when the UI is opened are those of the individual UI windows (cis.exe) The main process can hit 70+% and subsequent processes can go over 50% but they’re very short lived peaks.

Here’s a twist. I seldom turn off my systems, as they’re usually doing something. This system. with CIS 6, has now been up pretty much since my post above and I’ve noticed a gradual increase in the amount of time it takes to open and navigate the CIS UI. Everything else has remained consistent…

Edit: Things appear to have gone from bad to worse. After rebooting the CIS 6 tray icon is now the last to load - I only have four tray icons - by several seconds and the UI is back to being horribly slow to open and navigate. Nothing else has changed, nothing has been added or removed. Considering all the versions of CIS I’ve used since 2.x, version 6 is the only version that has ever give me problems.

I saw a post two days or so ago here where somebody shows a connection between higher DPC’s and Base Filtering Engine service (which is used for the traffic animation). May be there is a clue in this.

Thanks Eric, I’ll take a look at that when I can free up a PC. For now, I’ve removed version 6. Unfortunately, there are just too many things about this version that I don’t like.

I have never had this problem With CIS 6. Usually it take under 3 seconds for UI to come up.