CIS 6 Failed Installation

so i recently reformatted my system and decided to install CIS 6 on it however the installer just hung at 96% for around an hour. I eventually got fed up and tried to cancel the install but that got nowhere as well, it just said cancelling the installation but didnt do anything for a long time again. My internet wasnt working near the end of this process so i restarted my system with the hung installer but on restart it said the service agent cannot be initialized and doing a reinstall doesnt seem to work, just ends with the same result, asking me to restart and then again the service wont start. Furthermore, i cant uninstall the parts of CIS that already HAVE been installed, there’s no uninstaller in the folder so im stuck with a non-working CIS that wont do anything.

It asked me to make a diagnostic report so im attaching that here, how can i get this working?

[attachment deleted by admin]

Try running Diagnostics and see if that can fix it.

that was the first thing i did, it asks me to everytime i boot up and it fails everytime telling me in the end to create a diagnostic report which i attached to my first post

Hi Firzen,
To rid yourself of the failed installation I would consider running the unofficial Uninstaller Tool for Comodo Products in Windows Safe Mode if possible, this was not designed with V6 in mind but it still could help.

Also after check to make sure the Comodo Internet Security Firewall Driver and the Comodo Internet Security Helper Driver have both been removed, if not right click on the entry then choose uninstall.
Found in Windows Device Manager, select view Show hidden devices and look for these drivers under Non-Plug and Play Drivers.

i tried the uninstall tool yesterday after looking around a bit, it kept repeatedly giving errors in the cmd window, couldnt find the things it needed to remove.

You might want to try using system restore.When I had a faulty uninstall I had to reset my laptop to factory settings. This an option of nothing else works. Do you have your computer backed up?

tried system restore but it didnt really do much, i do have backups of my data, but i really dont want to have to reformat again after just doing it…

Yeah, I understand. Maybe Revo Uninstaller can help?

i dont have revo, but revos forced uninstalled feature might work, hopefully at least after reading the description. ill install the trial of it and see how it goes.

Definitely cant say id be comfortable recommending CIS 6 in its current state to anyone if shit like this happens on a newly reformatted system…

You can download a free 30 day trial version of Revo Uninstaller Pro from their website. Hope this helps.

revo’s forced uinstall SEEMS to have solved this botched installation, i no longer get the error at startup and i manually removed the driver from device manager. all seems good at the moment.

i want to try to install CIS again but im kind of hesitant if this was a one time fluke or a problem with this version of CIS

Make sure that left overs of previously installed security programs are no longer around by removing possible left overs with cleanup tools of those programs. Leftovers can cause all sort of strange results A list of such tools can be found here: ESET Knowledgebase .

i just reformatted the system, no security products were installed other than winpatrol which ive been using for years (with and without CIS before as well) i cant imagine a system that was just reformatted and only has WinPatrol running would be at fault.

I am glad Revo eliminated the error. I hope CIS 6 does not have another install error if you try installing it again.