CIS 6 blocking ssh for vmware server and bridged networking

I’m a web developer and have been using Comodo Internet Security since version 2. Seeing I’m home for a while, I decided to continue work from my office at home so I installed VMWARE Server, installed Ubuntu 12.02 32 bit server to continue my projects. Connection via bridged networking to the Internet is fine. I can ping the IP address and get successful results both from the Windows 7 host machine to the Linux vm and vice versa. But that’s it. Using Putty or mobaxterm to connect to the webserver in the vm and I get a connection time out. FTP to the server does not work as well.

I said, ok, no problem, just create some application rules and get it done with. Sorry, despite setting up the correct settings, I can’t connect. So, I figured it must be Vmware not playing nice over the wireless connection and so I spent over 8 hours researching online only to get no where. So, I opted to disable the firewall for 15 mins and to my surprised, everything went perfect. FTP, Putty via ssh works superbly, turn back on the firewall and I’m back to square one. Even with an application rule as:

  1. Application name: Putty
    TCP In/Out
    Source address: 192.168.138.2
    Destination Address: 192.168.138.15
    Source Port: Any
    Destination Port: 22

still nothing. So, I checked “log as a firewall rule if this event is fired”.

To my surprise, it still doesn’t work and not one event is found in the logs re the connection attempts. Just fails to connect.

Any help would be appreciated.

P.S Webserver can’t be accessed from the Host system but I can access it from anywhere else on the network.

Port 80 problem. I just discovered a VMWare problem in addition to my WAMP problem. Jesus -.-

I don’t see why this is a port 80 problem and VMWare. Had you read my post properly you’d have seen that I do get connection as long as the firewall is off. Besides, ssh runs on port 22, not on port 80.

Can you try the Outgoing Only policy and try connecting to your server in VM Ware?

When that does not work can you post a screenshot of the firewall logs and the Global Rules of the firewall?

Did a fresh install of Windows and Comodo. I’m still running into the same issue. When you said try the outgoing policy, is that for putty and the ftp client? as both are having the same issues. I did it for putty, making sure I clear all logs before attempting so whatever is logged would be for it. The logs are completely clear. Here are my global rules for my firewall. Like I said, it’s a fresh install. I have not added anything for now save applying the outbound rules and telling comodo what my home network ipv4 network range is made out of.

Edit. Made vmware an “allowed application” then made reattempted. Same problem. Got two logged entries for wcp the ftp programme and putty. See attached screenshot (firewall log)

[attachment deleted by admin]

Edit didn’t permit adding the 2nd screenshot so here is.

[attachment deleted by admin]

Can you see if the rule for System in Application Rules also has the two lines allowing all outgoing and incoming requests if the sender is in Home#1? If that is not the case please add two rules to the rule for System.

When that does not help run the Stealth Ports Wizard to set your computer to stealth settings (Block Incoming Connections).

This will change the Global Rules. Please edit the block rule at the bottom to block and log. That way we may get a more detailed view about what’s going on in the logs.