CIS 6.3 creates network problems in windows 8.1

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    It’s a permanent issue even after multiple reinstallations.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Just installed latest CIS 6.3 on windows 8.1
    b: The internet stopped working.
  • If not obvious, what U expected to happen:
    The internet should have worked.
  • If a software compatibility problem have U tried the conflict FAQ?:
    As far as I can tell this is not a compatibility problem.
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    It worked perfectly fine in windows 8. After updating to 8.1 I have the issue, even though CIS was fully reinstalled after the upgrade.
    I tried to fix it by changing settings in CIS. Even disabling all CIS protection modules (av, sb, hips, firewall) doesn’t fix the issue as long as CIS is installed. I also tried comodo uninstaller (from geekbuddy) found in the forums.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.3.302093.2976 default

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default configuration
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from a CIS 5?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 8.1 64bit with all updates, UAC disabled, administrator account, no virtual machine used.
  • Other security/s’box software a) currently installed b) installed since OS: a=None b=None

Are you able to access the internet at all?

Also, when you say you used the uninstaller, did you follow exactly the steps I recommend in this topic:

If not, then please do. Then, after running the uninstall tool, also manually check to ensure that the Firewall driver was removed. Only after that should you try reinstalling. Please follow the topic carefully and let me know if this can fix the issue. This sounds fixable to me. It’s likely caused by a leftover from the Windows 8 to Windows 8.1 transfer.

Keep me updated.


No, when CIS is installed I cannot access internet at all, not even CIS can. Even when firewall is disabled. But windows connects to router successfully and reports everything is fine.

I’ve done most of those things before but I decided to follow the guide just in case. So I did everything (excluding revo uninstaller and microsoft fix-it webpage as I have x64 version of win8.1). I also uninstalled malwarebytes & hitman even thought they were only on-demand. And then I manually looked for comodo related folders/files/registry entries. Still no result. Installed latest CIS with no change in settings (except unticking bundled software: dragon, geekbuddy & privdog).

Can you confirm that disabling the Comodo Firewall driver solves this problem?

Also, did you run the removal tool for all anti-malware software which used to be installed on your computer, but is now removed?


Can you please explain what you mean by “disabling comodo firewall driver”? I have disabled the firewall in CIS settings and the problem isn’t solved. I even killed the various comodo services using process hacker but problem still exists. Only uninstalling CIS solves it.

There are no removal tools as far as I can see for malwarebytes & hitman pro except their own uninstallers. But I did manually searched for leftovers.

Check section B.3 from my other topic. That tells you how to find the drivers. It would actually be best if you followed section B and tried reinstalling once more. For some problems just following section A is not enough. Please try following both.

Also, I think Malwarebytes and Hitman Pro should be fine. I was more worried about whether you had full suites on your computer, such as Symantec or McAfee.


I’ve already done that. I’ve searched device manager. I’ve manually checked for leftover files. I’ve manually checked for registry entries. I’ve run geekbuddy uninstaller in safe mode. Unless I’m missing something obvious (you can never know) there are no leftovers.

I can try other suggestions but it looks like I have covered all logical steps. Perhaps this issue can be treated as a bug. I’m willing to install test or debug versions if any comodo developer sees this post.

Thank you for checking that. I have now updated your first post so that it is in the required format. For future reference, just copy and paste the code. Then put your responses after the colons. Please look over the information in the first post, and ensure that everything is correct.

Also, please attach the diagnostics report and KillSwitch Process List to your first post.

Let me know if you have any questions.

Thank you.

Thanks for fixing the broken first post report. I edited the page to include the fact the OS is 64bit. I’ll attach the reports in the following days when I find the time to do so.

Thank you.

Have you been able to create the Process List and diagnostics report yet? Once you have attached these to the first post I can forward this to the devs.

Let me know if you have any questions.


I’ll have to reinstall CIS to get those reports and I’ve been very busy the last 2 days. I’ll certainly do it but it might take me a couple of days.

Thank you.

I reinstalled CIS to produce the diagnostics report and the problem is fixed :o Internet is working.
The only thing I have changed in my computer since the previous try is the update of VirtualBox from 4.3.4 to 4.3.6. VB has a network driver which could explain the issue if there is some incompatibility. But I had stopped the service to try CIS so I don’t know if that was really the issue.

Whatever the reason I’m happy to hear it’s working. Perhaps there was an incompatibility between the two drivers. I’m not sure.

However, I will now move this report to Resolved. Please let me know if the problem returns.

Thank you.