CIS 5.3: "Rule with such parameters already exists" but rules are different[318]

The bug/issue

  1. What you did:
    Under Firewall > Network Security Policy > Global Rules I added 2 custom rules.
    First rule: Allow TCP/UDP IN where DESTINATION PORT is SINGLE PORT 40000
    Second Rule: Allow TCP/UDP IN where DESTINATION PORT is SINGLE PORT 40001
  2. What actually happened or you actually saw: After clicking Apply on the second rule I received a message: “Rule with such parameters already exists”
  3. What you expected to happen or see: No message to pop-up as rules are different.
  4. How you tried to fix it & what happened: There is no fix, I simply ignored the message
  5. If its an application compatibility problem have you tried the application fixes here?: not applicable
  6. Details (exact version) of any application involved with download link: not applicable
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Yes, see point 1.
  8. Any other information (eg your guess regarding the cause, with reasons): CIS is not checking for port number when comparing rules

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Screenshots of the created rules
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: not applicable
  3. A CIS config report or file: not applicable
  4. Crash or freeze dump file: not applicable

Your set-up

  1. CIS version, AV database version & configuration used: CIS: 5.3.174622.1216, AV: 7244, Default Config
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No, clean install
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: not applicable
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: not applicable
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Stealth ports wizzard > Block all incomming connections and make my ports stealth for everyone
  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode, Sandbox= Enabled, Firewall = Safe Mode, AV = Statefull
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 32bit, UAC on Default, running as Admin
  7. Other security and utility software installed: None
  8. Virtual machine used (Please do NOT use Virtual box): None

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation