CIS 5.3.181415.1237 prevents RegShot from running correctly. [NBZ]

I am running the latest CIS (5.3.181415.1237) on my W7 x64 system and RegShot ( now fails to run correctly. It also runs 4 or 5 time slower than before. I exited CIS and RegShot still fails. Using the xxGuard.dll fix, RegShot does seem to run correctly but still 4 or 5 times slower. I am not sure which version of CIS started seeing the problem but it is recently. As far as I am concerned, when I specify an application as Trusted, it should not be interfered with at all by CIS. The slow down and function loss is unacceptable. If I remove CIS from my system, RegShot runs fine and fast.
I am also concerned what other applications are also suffering this problem unknown to me at this time.

Note. The xxGuard.dll (xx is 32 or 64) fix is to rename the files.
Thanks, John.

CIS 5.3.181415.1237 prevents RegShot from running correctly; also 4 or 5 times slower.

The bug/issue

  1. What you did:Ran RegShot ( full registry shot (scan).
  2. What actually happened or you actually saw:Required 4 to 5 times (>20 seconds) as long as when CIS is not installed. After compare clicking OK caused application to hang and not create IE display of results.
    Sometime D+ Events says Partially Limited and sometimes Scanned online and found safe
  3. What you expected to happen or see: 5 seconds. IE display to open after clicking OK.
  4. How you tried to fix it & what happened: Turned off CIS - no help, Used xxGuard.dll fix, IE display worked but still slow.
  5. If its an application compatibility problem have you tried the application fixes here?:?
  6. Details & exact version of any application (execpt CIS) involved with download link:RegShot (
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Just run the application and it happens every time.
  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.181415.1237, 7911, Proactive
  2. a) Have you updated (without uninstall) from CIS 3 or 4: Fresh install on a fresh W7 install.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):No
  5. Defense+, Sandbox, Firewall & AV security levels: D+=SafeMode , Sandbox=Enabled , Firewall =SafeMode , AV =Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type:W7 Ult x64 SP1 64 bits UAC off Administrative account
  7. Other security and utility software installed:None
  8. Virtual machine used (Please do NOT use Virtual box):Fails the same way on HW and VMware Player.

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


HeffeD, done. Am I suppose to send it somewhere or just post it here? I have no files to attach. Thanks, John.

Thank you for your bug report in the required format.

Moved to verified.

Thank you