CIS 4 - Windows 7 x86 - No Internet Connection - SOLVED

Hello everyone,

I am a Comodo user since version 2 and I got much help in minor problems by searching through the forums. However, this time I could not find any relevant information about my problem so I decided to post here for help. I have installed Windows 7 x86 on my Lenovo 3000 N200 laptop. Immeadiately, I have installed latest CIS 4 only with firewall option. And I could not connect to the internet, neither through LAN at office nor through wireless at home. I have also installed the latest dirver for wireless, still no success. I have tried installing CIS 4 with “run as administartor” and in “vista compatibility” modes. But still the same result. I have also run the Comodo diagnostcs bu the program did not detect anything. So, I uninstalled CIS 4 and the computer could connect to the internet without any problem. Definitely CIS 4 was the source of problem. Then I have installed Online Armor just to check whether Windows 7 does like 3rd party firewalls or not. However, Online Armor did not cause any connection problems. Now I am running Online Armor on my machine. However, I want to go back to Comodo as soon as possible if you could help me solve the problem. Thanks everyone in advance…

I have re-installed Windows and Comodo. However, still the same result. Does aynone have any suggestion?

Did CIS report a new network found? If so, how did you answer?
If not, go to More/Settings/General tab. Make sure ‘Automatically Detect New Private Networks’ is checked.
Click ‘OK’ and restart your computer.
It should find your home network (Wireless, I gather from your post) upon logging in.

Yes, mate listen to John and you will find solution for your problem!!!

Thanks a lot, John. Comodo did actually find my home network. I get connected to my home network however, I cannot access internet. Worse than that my computer freezes immediately after booting. I quickly exit Comodo after boot up. Only this way I could avoid freezing. I have uninstalled Comodo altoguh I was too happy with it. I had a similar experience with one of v3 releases and Vista constantly getting BSOD immediately after login. After several releases I tried v3 again and I could successfully use Comodo. Most probably it has something to do with the hardware altough I am always using the latest drivers. I hope it would be fixed in time after sevral releases. Thank you very much for the reply anyway, John.

What Global rules did the firewall create?

[attachment deleted by admin]

Hi John,

Thank you very much for your reply. I solved the problem. I am using G Data Antivirus Client. I could connect to the internet when I unchecked the Options–>Web/IM Filter–>Process Internet Content box. When I have installed Online Armor this box was checked, too. However, seems like Online Armor and this combination can somehow connect to the internet. However, I was experiencing slow connection and Firefox was not launching very easily. Now, everything seems to be OK. Though, I could not understand the reason of this problem because on Vista I was using Comodo FW with this option of GData checked. I am back to Comodo again! :slight_smile: Thank you very much for your help.