CIS 4 Locks me out of Internet [overnight]

Hi,

After rebuild of PC - XP Pro SP3 I installed the latest version of CIS, 4.xx. Internet worked initially but overnight drops out. Local Area connection shows that I am connected @ 100Mb/sec, listing packets sent and recieved but no IP address.

IP address in CIS listed under Firewall TCP/IP: 192.168.0.10

Uninstalled CIS 4.xx, rebooted PC and now can send this post.

No other changes made to PC, Cable modem or setup.

Would appreciate help.

Did not have this problem with CIS 3.14.xx.

Regards,

KH

Did you set CIS to trust that Local Area connection?
Have you set CIS to block all incoming connections?

Thanks.

Hi OmeletGuy

“Did you set CIS to trust that Local Area connection?
Have you set CIS to block all incoming connections?”

Yes to the first question, not sure about the second but after the initial install of Ver 4 the internet worked for a while. It was only overnight, when I suspect CIS was updating itself, that the Internet connection drops out. This repeatedly occurred over a period of a few days. The only way I could re-connect the PC was, using my laptop, to log into the router and delete the IP license for the PC, reset the modem and reboot the PC.

However last night I reinstalled CIS Ver 3.14.xx and overnight there were no problems with the Internet this morning as sending this reply, something that I could not do with Ver 4.xx loaded.

Also I noticed that with Ver 3.14.xx loaded the PC starts quicker, by at least 2 – 3 minutes than with Ver 3.14 loaded. Previously with Ver 4.xx loaded the PC would start as normal through the ‘post’ screen, bring up the Windows logo, the Welcome screen and then gradually the Desktop, the outline of the Desktop Icons would load and then the images would load one at a time. Once this was done the HD would pulse at about 1 -2 flashes per sec for at least 2 minutes then load the system tray icons, the Scanner drivers etc, and them at least 1 more minute to the finish. Now with Ver 3.14.xx loaded the time from start to full load is about 1.5 minutes.

Also Ver 4 brought about a system crash and I have sent the DMP file to COMODO but included the text here. I have had no crashes with Ver 3.14.xx loaded on this machine or my Laptop which has had Ver 3.14 loaded for several months. After reloading Windows XP and re-establishing all my programs I reloaded CIS Ver 4.xx without any crashes but still had the issue of the Internet connection dropping out.

I think that there might be an issue with XP and the difference to Vista-Win 7 systems regarding Ver 4.xx?

Regards,

KH

Had a major crash yesterday that affected my computer. The error message said the Comodo Internet Security had caused a problem and had to shut down, and asked me to send the attached file to COMODO. However, as a result of the crash I lost my Internet connection, the crash affected my onboard LAN drivers, and I could not send the Error DMP file to you.

Thankfully I was able to store a copy of the crash file off computer before reloading XP Pro. So I downloaded Microsoft Debugging tools and decoded the CRASH file as below.

The PC now runs OK and I have scanned all my HD drives, USB drives and memory sticks without detecting any virus or other malware via CIS Premium, version 4.1.150349.920.

This is the same version that was loaded when the crash occurred. However I am not sure if it was CIS that caused the crash?

Regards,

KH

Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [F:\Error Files\cfp\CRASH.DMP]
User Mini Dump File: Only registers, stack and portions of memory are available

Symbol search path is: *** Invalid ***


  • Symbol loading may be unreliable without a symbol search path. *
  • Use .symfix to have the debugger choose a symbol path. *
  • After setting your symbol path, use .reload to refresh symbol locations. *

Executable search path is:
Windows XP Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
Product: WinNt, suite: SingleUserTS
Machine Name:
Debug session time: Sat Jul 10 15:43:27.000 2010 (UTC + 10:00)
System Uptime: not available
Process Uptime: 0 days 0:00:02.000

This dump file has an exception of interest stored in it.
The stored exception information can be accessed via .ecxr.
(d4.100): Access violation - code c0000005 (first/second chance not available)
eax=00196000 ebx=00195d08 ecx=0012ce44 edx=00001000 esi=00195ce0 edi=00195d38
eip=7c90e514 esp=0012cd90 ebp=0012cda0 iopl=0 nv up ei pl zr na pe nc
cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000246
*** ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll -
ntdll!KiFastSystemCallRet:
7c90e514 c3 ret

The problem of loosing your internet connection may be caused by having “Block fragmented IP datagrams” enabled (it is enabled by default). The setting can be found under Firewall → Advanced → Firewall Behaviour Settings → Advanced.

Does disabling that do the trick fr or you or not?