CIS 4 installation error 1603 [ALMOST SOLVED]

Hello all,

I also have troubles installing v4, although my situation is a bit different. My problems started with the latest update to CIS. The updater kept saying that there was an update available, but after installing and a reboot it told me so again. In order so stop this eternal update loop, I uninstalled CIS, cleaned and installed but now CIS wont install.

I tried the cleanup tool and updated my windows installer to v4.5. Everytime I install, whether it is only AV, FW or both, after installing the kernel drivers (I have to click though the logo tests) it rolls back instead of finishing the installation. I project that is the reason why the update earlier never completed.

My system is Windows XP x64 SP2, with nForce 4 chipset. Also some other network drivers are present, such as Virtualbox and Bluetooth, but the problems remains when I removed those.

I have included a MSI setup log of the latest attempt, perhaps that one of you kind folks can see the reason why the installer decides to rollback, because obviously it detects an error during installation, but I cant figure out what.

Please note that a previous topic by me got merged by a NON ADMIN, and after that nobody would look at it ever again. But the errors I experienced were different, in that I never got the screenshot the other users posted.

[attachment deleted by admin]

I have tried some more, including the msi cleanup tool, 1603 fixup suggestions like checking system user rights, but to no avail. However, I have been able to narrow down the area where the installation goes haywire. As I said, after installing kernel drivers (and clicking through the security messages about installing the drivers), the system goes into rollback instead of displaying finished.

Now the MSI setup log displays that things go wrong in the InstallFinalize with return value 3. I have included the log again, you can see this message at line 4505. Any COMODO programmers known what the installer attempts to do in this finalize?

[attachment deleted by admin]

I got this one fixed, with help of the guy in the main 1603 error thread that describes the disable rollback procedure. However, I still get this error when I run the CIS self diagnostic. This is the error report it gives:

(The regkey that failed gives an error that I cannot open it in regedit, and I dont know whats wrong with the component, because the file is present in the location.)

<?xml version="1.0" encoding="utf-16"?>



 ...

  <RegValue Status="Ok" Name="LoadAppInit_DLLs" Type="DWORD"
  Expected="1" />
  <RegValue Status="Ok" Name="AppInit_DLLs" Type="String"
  Expected="C:\WINDOWS\system32\guard64.dll"
  Comparsion="FindSubstring" />
</RegKey>
<RegKey Status="Failed"
Path="HKEY_LOCAL_MACHINE:SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows">

  <RegValue Status="NotVerified" Name="LoadAppInit_DLLs"
  Type="DWORD" Expected="1" />
  <RegValue Status="NotVerified" Name="AppInit_DLLs"
  Type="String" Expected="C:\WINDOWS\SysWOW64\guard32.dll"
  Comparsion="FindSubstring" />
</RegKey>
.. ..

Mine was this HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Window
I solved this, by :
Right-click that key > Click Permissions > Advanced > Owner Tab > Change owner to Administrators.

My COMODO error diagnostic file now has 3 “FAILS” instead of 5 originally.
I am now only being bothered by this line :