CIS 4.0.138377.779: network path not found

I recently upgraded from CIS 3 to CIS 4.

Suddenly my mapped network drive (which is mapped to a shared folder on a WD MyBookWorld network drive) cannot be found.
This is very strange, at the same time this is happening, I can connect and browse the same network folder through another computer on the same network. I’m using that computer through VNC, so I know for a fact that there’s nothing wrong with the connection on either computer.
I can’t find anything in the logs or pending files or whatever.
Not in the Firewall Events, not in the Defense+ Events.
My Blocked Network Zones are empty.

I tried setting the levels to disabled, but that didn’t seem to have any effect.
I had the settings on “safe”.


CPU 64 bit
Vista 32b Home Premium, all uptodate, latest pack and fixes
Just CIS 4 and my common sense as protection
Administrator account
UAC Disabled

Hi Maestr0,

Are you able to “ping” the network drive on IP number or “name” ?
How do you connect to that device, did you use “Map drive…” or some new “Windows Vista/Win7” trick to detect local devices?

One other thing you could try is to untick the Firewalls, Behavior, Advanced, “Block Fragmented IP datagrams”.
That has been causing issues in the past also.


Thanks for you quick response.

I was not able to ping the network drive by name, but I was able to ping it by IP.
I used Map Drive… to map it, with an auto-connect on startup. I have (purposely) not touched the mapping, so something else must have changed.
Before, I used to see the drive in my Network, but not any more.

However, I was able to map the drive using the IP instead of the name. The IP is in my allowed range

I saw that setting but hadn’t unticked it because of the line “This option must not be disabled unless necessary”.

While I was browsing through the settings once more, I manually added the home LAN I set up as trusted… this did the trick! Suddenly, I’m able to connect to the network drive by name as well (even when I re-tick the button you suggested I untick).

I seem to recall when installing that it asked me for a trusted network, guess I was wrong.

Should anything change, I’ll post it in this thread.

Well done :-TU Sounds like it was blocking Windows from discovering the local network by name.

Thanks ;D

I realised I didn’t specify how I specified the network as trusted, so here goes:

L> common tasks
L> Stealth Ports Wizard
L> top selection : Define new trusted network
L> top selection : Zone Name

I had the exact same problem at work. It took me some time to figure it was Comodo firewall that was the problem. I’m happy I’m now able to reach the network using Maestr0 solution, but I considere that solution as a workaround, since I’ve never wanted any network path to be blocked!

I’d like to know :

  • Why did Comodo block me from accesing this network path? What rule did it use? Where can I see that rule and disable it to prevent future problem?

  • Why didn’t Comodo asked me to allow or not the access to this network path the first time? Usually it pops me notifications for every new outbound connection it doesn’t already manage…

The Global Rules changed with v4 to blocking all incoming traffic (default stealth). In the default rules of v3.x you would be alerted for incoming traffic and CIS would make the rules according to your answers.

But this is not incoming traffic, right? I’m trying to access the network path…

And I use Comodo 3.14.130099.587.