CIS 3.9 Update & Clean Install = Blue Screen

PC = Dell Dim 8400 - XP Pro SP2 32bits running Spybot S&D, Snoopfree, Winpatrol, AdAware Anniv Ed.,
Windows Steady State (off),Avira Free AV and CIS 3.8…477 (firewall only - never installed AV)

Laptop = Dell Insp 8600 - XP Pro SP2 32bits running Spybot S&D, AdAware Anniv Ed.,
Windows Steady State (off), Avira Free AV and CIS 3.8…477 (firewall only - never installed AV)

Hello Forum,

I’ve been using the above setup ‘forever’ until 2 or 3 days ago I tried to update CIS 3.8
On the Laptop, I got Error 108 repeatedly, so I ended up doing a clean install of CIS 3.9 and that works fine now. Still only using firewall only with Avira AV.

The continuing issue is on the PC.
Accepted the update from CIS 3.8 to CIS 3.9 and on reboot got a ‘blue screen’.
Screen message indicated that “there were problems and windows shut down to prevent damage, and Removing newly istalled drivers/softwares should fix the problem”.
Rebooted in Safe Mode and did a Sys Restore to previous day and PC was back to normal (with CIS 3.8)
Tried it again and same thing happened, but this time in Safe Mode I uninstalled everything Comodo
even from Registry.
Also uninstalled Avira AV because I decided to used CIS AV if 3.9 was installed without problems.
Downloaded CIS 3.9 from Comodo website and installed … same ‘blue screen’.
In Safe Mode I unistalled 3.9, reboot into Safe Mode and tried installing again. Same ‘blue screen’.

So, again in again Safe Mode I uninstalled CIS 3.9, rebooted and installed CIS 3.8 both the AV and firewall.
Keep getting notification box that “updates are available for CIS” but that will start this issue all over again.
PC current config with CIS 3.8 with AV and FW installed works fine, AV update and scan without any problems and PC other security softwares fuction as they should.

Please help/advice me if there is a solution or fix to this.


Keep and eye on the website, 3.9.509 should fix the blue screen. They have released it but only though an update, the problem is if you install 3.9.507 and get a bluescreen you can’t update to the newest version. Try updating in safe mode. Go to safemode with networking and open comodo. Go to the Misc tab and check for updates, you might be able to get them that way.

Just tried to update in safe mode as instructed in previous post…
Got ‘Error 118’ update was not completed.
Rebooted and CIS System Status says ‘initializing’ for quite a long period.
Uninstalled CIS 3.8, rebooted, then installed 3.8 again.
Back to normal … CIS AV & FW working as should.

Guess I’ll have to wait until 3.9…509 is released on the website to try that.

I actually found the download link get it form here :smiley: 32bit 64 bit

Downloaded CIS 3.9…509 32bits from link provided.
Uninstalled CIS 3.8…477 Also deleted any CIS files in Program Files and Registry
Rebooted into Safe Mode with Networking and installed CIS 3.9…509
On restart … ‘Blue Screen’ again.

Rebooted into Safe Mode
Uninstall CIS 3.9…509, restart and no ‘Blue Screen’
Installed CIS 3.8…477 and restarted.
Everything back to normal.

I moved your post to the bug boards. Would you be so kind to submit this bug?

Please read this sticky topic about how to submit a bug: . Remember to submit the minidump as requested in the sticky topic.

Thanks in advance for your cooperation.

CPU: 32Bits
OS: XP Pro SP2
Sec & Util: Spybot S&D, WinPatrol, SnoopFree, AA Aniv. Ed., Sandboxie,
Avira AV & CIS FW 3.8…477
Bug: Update CIS 3.8, restart at end of update - get blue screen which says
something like “there were problems and windows shut down to prevent
damage, and removing newly installed drivers/softwares
should fix the problem”.
Clean install CIS 3.9 - same results
Resolve?: Uninstall Avira AV
Remove everything Comodo from PC incl program and registry files
Install CIS 3.9…507
Repeat in Safe Mode
Repeat in Normal and Safe Mode installing 3.9…509
Uninstall CIS 3.9 and install 3.8…477 AV & FW - all working fine.
Setting: Default - never modified
Reboot: No - no dump file
Admin: Yes

For reference, I have the exact same problem described here:;msg287691#msg287691

There are other users who have the same problem, relevant threads are referenced on the post above. My crash dump is also available a few posts prior on the same thread.

Hello xfile

Can you please post the versions of the security software you have installed ?

Can you also post your BSOD minidump here:

You can find more minidump info here:


Installed Security Software are:

CIS 3.8…477 - FW only when problem first occur / Now have FW & AV and still cannot update to 3.9
WinPatrol 16.0.2009.0
AdAware 8.0.4
Snoopfree 1.0.7
Spybot 1.6.0 TeaTimer On
Sandboxie 3.36.04

SpywareGuard 2.2
Arovax Shield 2.1.103 - Off for many months
Windows Steady State 2.5 - Off/Driver not installed

Avira AV [ver?] was installed when problem first occur

Re: Minidump
Dr. Watson is empty, I probably cleaned/cleared it when I ran CCleaner recently.
Or do I have to reproduce the issue to get the minidump file?

If you could yes please, it think it would be valuable to the dev’s to have an extra minidump regarding this issue.


Maybe I don’t know how to get that minidump file, please advise me.
I just reproduced the problem …
Updated 3.8…477 and restarted, result = Blue Screen
Reboot into Safe Mode and uninstalled CIS (now 3.9…509)
Restart and installed 3.8…477, all back to normal.

Then I searched for the minidump file
Found C:\Windows\minidump f͘older which was empty.
Run drwtsn32.exe nothing there either

Am I doing the right thing to get that minidump file?

Normally if you have a BSOD it will tell you it’s dumping the contents to a file on the bottom of the BSOD screen, once that is done you can power off the computer, and restart it again.

There could be a file called c:\windows\memory.dmp or there could be a file on c:\windows\minidump

I saw somebody had CCleaner active to clean up that specific folder at startup so that could also cause no files to show up there…

Try to disable the TeaTimer. I’ve seen some incompatibilities with it.

It has been confirmed by Egemen that Snoop Free is the problem.;msg288367#msg288367

You will have to uninstall Snoop Free.

As Egemen said it will be added to CIS blacklist as incompatible software because it attacks CIS hooks and doesn’t bother to distinguish between Security software and a rootkit.


OK Guys…

I uninstalled SnoopFree from Add/Remove Prog. and from Registry, restart.
Uninstalled CIS 3.8…477, restart.
Installed CIS 3.9…509 and … [drumroll please]


CIS 3.9…509 is up and running, virus database is updating and my PC is normal.
[SpyBot Tea Timer is on]

I think that’s the fix … if you have SnoopFree - get rid of it.

Thanks Egeman and the rest of the forum for your help ;D