CIS 3.8.65951.477 fails to update signature file

I have upgraded from version 3.5… to 3.8.65951.477 and antivirus updates have stopped working when I’m at home without a proxy. Antivirus updates work at the office when the proxy is enabled in Internet Explorer.

When I check CIS proxy settings they appear correct and are equal to those shown in IE 7.

I’m using Windows XP SP2 32 bits with 2GB of RAM.
My account has administrator rights, Defense+ and firewall are in safe mode and antivirus is enabled.

Any idea on how to solve this? Thanks.

If, at any time, you imported your 3.5 configurations, the registry keys got changed.

Check these registry keys:

Database update registry keys:

HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

Also check: \1\AV\Settings

UpdatePath has to be: av/updates38
UpdateURL has to be:

UpdatePath has to be: av/updates38 UpdateURL has to be:

I just checked the registry keys. They are OK.

Anyway, thanks, any other idea?

Still not working. Can anybody help me? Anybody with the same problem (updates working behind proxy, not working at home without proxy)?

I have same problem. Since I upgraded to 3.8, virus signature updater doesn’t work (it goes to 5%, then error message: “Failed to update the virus signature database”).

I checked my registry keys and they are ok, I also checked if I can reach update URL and I can. I do not use any proxy.

I already had same problem with Betas and RCs, but it was resolved in final release. It seems this bug made a comeback in 3.8. :-\

It is recommended to do a clean install instead of an upgrade install from 3.5 to 3.8 due to the changes in the database.

Did that. Cleaned registry and filesystem of all Comodo related entries before reinstalling too.

No luck!

Same problem. I followed all the suggestions in this thread. If I can’t keep the av db up to date, I’m going to have to dump CIS soon. There hasn’t been a response to this in over a week!

I hope this problem will be fixed soon, becouse Windows keep complaining my A/V is outdated.

Comodo already had exactly same problem during development of CIS, all Betas after Beta2 and all RCs had this problem. It started to work in final release though, and until last upgrade it worked - now suddently same problem.

Reinstall doesn’t help, registry keys are OK, internet connection works (besides it worked before the upgrade).

@jfmart. Are you using the same system, laptop, at home as on your work? Or are those two different systems?

I love Comodo’s products, but, I’m sorry, this is a show-stopper bug but it doesn’t seem to be being treated as seriously as it deserves. O0

I have same problem. I install the 3.8 in a clean PC. It can updated in the first weeks, but from this week, the virus signature updater doesn’t work (it goes to 30%, then stop and error message: “Failed to update the virus signature database”).

i facing same problem with updates it hangs on 30% and fail, its one of the serious issues CIS facing lets hope developers will fix this serious issue as soon as possible. :-La

I can only get it to update the signature file if I do a clean install and it is becoming
Very Annoying! having to uninstall & re-install every three days .

Product Version 3.8.65951.477 - x32

Virus Signature Database Version 994

hey everyone…
iam also facing the same prob…however this may not be a solution…i’ve tried updating CIS during wee hours of night somewhere around 3am - 4 am…and i was succesful…i really think this is a very annoying bug…comodo is providing a nice package free of cost to home users…really appreciate that…but what good does the produst do if you can’t update it??? ;D

you clicked the bottom “update virus datebase” and update successful only once every installed state?
mine is so slow but can complete whatever.
is there any hint shows that your update was failed?

I don’t think that 994 is the latest update.

My friend has the same error. The download starts… and then stops in half a second… He even is not able to update CIS - Updater reports an error. Can you help? Can this bug be fixed without re-install?
CIS version 3.5.54375.427
Database upd. 994

I am sorry but the signature database has changed when the new version of CIS was released 3.5 is no longer supported, only the CIS 3.8 version is compatible with the new database.

Thanks :slight_smile: