CIS 3.5 oddities

I finally got around to upgrading from CFP 3.0 to CIS 3.5 using the internal updater, and all went smoothly. I ended up with only the 3.5 firewall (which is all I wanted) and all seem to work well, including D+.

However when I run msconfig.exe>Startup tab, I see 2 Startup Items, both titled cfp, and both loading from HKLM\SOFTWARE\Microsoft\CurrentVersion\Run.
For the first entry, the command is C:\Program Files\Comodo\Firewall\cfp.exe -h
For the second , it is “C:\Program Files\Comodo\Firewall\cfp.exe” -h (note the added parentheses).

When I check my my WinPatrol PLUS> Startup Programs tab, I see 2 entries:
COMODO Firewall Pro
COMODO Internet Security

When I open my Control Panel>Add or Remove Programs, all I see is:
COMODO Firewall Pro

Is all this as it should be, or have I done something wrong? Anything I should delete?

I’m using XP MCE 2005/sp3 here.

The entry for COMODO Firewall Pro in WinPatrol is more than likely obsolete (the uninstaller must have left it).

As for the msconfig entries I am not sure. I guess the second entry is the new entry… try disabling the first one and see what happens. Since it is only the client application your security is not compromised when it doesn’t start with Windows (you can always start it when in Windows).

With D+ you don’t really need WinPatrol anymore of course (:nrd).


Thank you.

Disabling the Comodo Firewall Pro entry in WinPatrol PLUS solved it. (That’s one of the reasons I keep WPP- not for resident protection, but as a startup manager. Also for its file info look-up capabilities).


Glad you found it. I use Spybot for changing the most common autorun stuff. For the rest I use Autoruns.