CIS 3.5.57173.439 and Vista Business Ed. 32 bit - STARTUP PROBLEMS

I have a very weird problem with CIS 3.5.57173.439 on a Vista machine. The machine is clean, I am very sure of that so don’t even bother suggesting any presence of malware of any kind.

Part A) Comodo does not appear (anymore) in the taskbar unless I start it manually.
a-1) And yet, even if I don’t start it manually and even if the icon is not there, the Vista’s Security Center is telling me that Comodo is active, up and running (including the service and stuff).
a-2) Even so, if I run some new program, the Defense+ popup warnings DON’T appear

Part B) If I start it manually the icon appears and as I start using programs the Defense+ warning popups or the “learning” baloons come up.

Part C) Looking in the “Miscellaneous->Settings” the option “Automatically start the application with Windows (recommended)” is UNCHECKED. So I CHECK IT and close that window. But if I re-open the window, that option related to autostart is STILL UNCHECKED as if I never touched it.
No matter what I do and how many times I repeat this operation the result is exactly the same: that bloody option remains UNCHECKED :slight_smile:

Part D) Ok, so I figured out I need to fully uninstall, clean the registry (using CCleaner for example) and do a full reinstall of CIS. But for some unknown reasons COMODO DOES NOT APPEAR in the list of installed programs :slight_smile:
(Someone suggested Revo Uninstaller but Revo doesn’t show it up either :slight_smile: … )

Part E) If I try to run it, the CIS setup acts pretty Ok, but it probably considers I just want to repair an existing installation. So it does absolutely nothing new to the list of installed applications, nor the “autostart” option

So the circle is somehow closed.
I know I am not a paying customer but I still hope that you will help me.
I have been using Comodo as my main Windows firewall since “Personal Firewall” 1st appearance on the net.
And I’m happy with it. This is my 1st major problem with Comodo.

Best regards

Goodday and welcome to the forum ( I think you are not entirely new… :wink: )

I had same problem of the icon not showing up, but manually starting the application and do a couple of reboots has solved my issue.

Your other problems part C and so on, could be well registry related problems, I suggest this:

[1] download and install revo un-installer (I myself use the portable version)
[2] run revo installer in advanced mode and reboot. (clean all registry entries of comodo and related files)
[3] download and install CRC or comodo system cleaner.
[4] close down all application and unnecessary background apps in the taskbar.
[5] run comodo registry cleaner. (create resore points!)
[6] run ccleaner and if you use comodo system cleaner, use the cleaners of comodo system cleaner… (make back ups!)
[7] install latest stable CIS and reboot

Let me know if this has worked out for you, I know you tried yourself uninstalling and installing again, and you used ccleaner and stuff… but please try to do some stuff in the list, you have not tried before, it could be the missing key… :wink:

Let me know if things worked out well for you,

Have a nice day!

Thanks for the answer but I already solved it in my own way.

  1. Restarted Vista in Safe Mode
  2. Deleted all the files in “%windir%\Program Files\COMODO bla-bla-bla” folder
  3. Run a CCLeaner instance and clean up most of the “suddenly obsolete ;-)” registry entries related to CIS
  4. Run the CIS setup again
  5. Made sure this time I have COMODO in my installed applications list
  6. Made sure the “Miscellaneous->Settings->autostart” option is CHECKED as it should be
  7. Restart the system in normal mode
  8. Manually create a system restore point, just in case :wink:
  9. Get happy again and post this answer on the forum :slight_smile:

Frankly I still don’t know what was the cause of this …

I am glad you have solved your problem, still I think the registry cleaner and the complete uninstall with Revo in advanced mode could have done the same, but better… I am not bringing you down, just saying these cleaners can search your entire computer and thus make sure you delete as much as possible…