CIS 10 upgrtade install gets stuck

I’ve just had a second machine get stuck during the upgrade from CIS 8 to 10. The install gets to around 46% overall and 85% in the installation and then sticks in cmdinstall.exe. It doesn’t fail, it simply doesn’t progress. With the first machine I left it alone for several hours in the hope that it would complete but in the end I had little choice but to reboot anyway, even though I knew there was an outside chance this would cause problems. However, upon rebooting version 10 seemed to be working OK. I left the second machine for a shorter time and then rebooted and again it came up running version 10 with no apparent problem.

In order to investigate, we will need log file that can be found in following format under system’s temp folder:



This can help us investigate problem further.


I found 3 cmd_install logfiles on temp for one of the machines. I’ve attached them in a single 7z file. Strangely, I can’t find any recent on the other machine, even though there are some old ones. No idea how that could happen as I don’t have any automatic clear of my temp folder.

Thanks, that was fast, appreciated!!

Any more information on this?

I have a fresh system install from a WIN 7 SP1 disk. No other programs on it. I downloaded the CIS 10 installer.

Try #1) It froze at 54 Percent and also knocked out my Internet. Cancelling the install froze too. I had to kill the program in Task Manager. Internet did NOT come back on. The Windows network troubleshooter was unsuccessful. It indicated the driver, but it was not specific (would this be the Comodo Firewall driver?). Anyway, I restored to a point PRIOR to the CIS firewall driver and the internet came back on.

Try #2. I turned off Windows firewall in case it was interfering. I tried to install CIS 10 again… It froze again and killed my internet at 54 %. Cancelling the installation froze again also! Anyway, I used Task Manager to kill the program, but this time, my internet came on by itself - I was surprised!

ODDLY: Comodo CIS 10 seems to be running fine. How can that be? The firewall is in safe mode. I even updated the virus definitions and did a quick scan successfully. It also seems to be monitoring traffic correctly. I can view the incoming and outgoing IP addresses. The Widget is on. The Home / Settings screen and all the settings seem to be working properly. It shows my system as “secure.” Should I assume it is functioning properly?

Should I do an offline install?


I had similar situation. CIS 8 was working perfectly fine. I finally decided to upgrade to CIS 10 using build in update tool. That was a big mistake. During the upgrade process, the update procedure hanged on running cmdinstall.exe around 45% of total progression. Ended up rebooting PC and breaking completely CIS installation. I couldn’t uninstall CIS using Windows’ Application manager or CIS installer. I couldn’t reinstall CIS by using it’s own installer, it tried to upgrade files first, but couldn’t because they were corrupted.

I ended up manually deleting files, folders, drivers, registry entries and autorun entries. It didn’t help either, I finally found a CIS removal tool which removed some last pieces of remaining installation. Then , an hour later, I could make a fresh install of CIS 10. That was a really bad user experience. IMHO CIS should make an automatic restore point before migration like this, if system restore is enabled on current PC. Or maybe some other backup that could be used in case of unsuccessful upgrade process.

I’m glad I managed to reinstall CIS 10 and that the upgrade process didn’t corrupt my Windows installation / boot sequence. It kinda sucks that I lost my config though. It’s been almost two years since last clean install. :frowning: