CIS Failed to Connect To Windows Service[2229]

like CIS, with CIS I have the error message : “Failed to Connect To Windows Service”
and cis.exe don’t start


Is there any file with .dmp extension under : C:\ProgramData\Comodo\CisDumps ?

Hi Lilith_unique,

To investigate more, please provide the

  1. Diagnostic report by using this guide,
  2. dumps if any available as windstorm stated,
  3. msinfo32 file by searching msinfo32 in Run command window and save as msninfo32.nfo
  4. Export Windows logs of Application, Security, Setup and System from Event Viewer

Thanks in advance.

Kind Regards,

I continue to experience that issue as well. The main problem is that the failed connection is forcing you to use a windows profile with administrator rights. Using a user profile leads to no success and there’s no desktop in sight. Instead, I have to restart the computer.

However, there’s an interesting little twist:

  1. When I first log in to my administrator profile, I get the message “Failed to Connect To Windows Service”.
  2. The taskbar doesn’t get the Win 7 look. Instead, it looks grey and Win 98ish. Just like the entire rest (windows explorer, control panel etc.).
  3. I then log out of my administrator profile and immediately log back in again.
  4. Interestingly, the taskbar takes on its usual Win 7 look now and there’s no error message anymore.
  5. I get curious, log out of my administrator profile to then log in in with my user profile.
  6. Et voila, I see my desktop with its Win 7 look and there’s no error anymore.

Long stories short, I log in once as an administrator, log myself out immediately and log in with my regular user profile–and apparently the problem is gone and the service has loaded correctly.

Can anyone with the same issue reproduce that? I know that it’s hardly a fix, however, I can at least use my regular windows profile again.

the diagnotic file of CIS is attached
impossible to upload file msinfo.nfo

The behavior of my PC is like ComGer :
log with administrator profile : taskbar and windows are grey (have to restart the windows service “theme” at each start of win7)
comodo don’t start : have to click “comodo” icon

but with the user profile : any problem, comodo and win7 start correctly

the bug is only with the administrator profile

when windows start : cistray.exe is suspended

the directory “C:\ProgramData\Comodo\CisDumps” is empty

You can zip the .nfo file and attach it that way. Also which use account did you install CIS on? The user or administrator account?

I installed CIS with administrator account and like administrator


an idea about this bug ?
a new version of CIS to solve this bug is scheduled ?

Hi Lilith Unique,

Thanks for providing diagnostic report and msinfo32 files.
please also provide the windows logs as requested, which we need for the investigation.
Thanks in advance.

Kind Regards,

[s]an idea to reduce the files of the event viewer ?
i can delete/erase all event and restart the PC for a new reports ?

20Mo per view…
Restrictions: 20 per post, maximum total size 15500KB, maximum individual size 15500KB[/s]

my bad
see the .zip of each report

Hi Lilith unique,

Thank you for providing the requested files. We will let you know if any other details are needed.

Kind Regards,

no update scheduled ?

i uninstall comodo ?

Hi Lilith unique,

We are working on it. Thanks for your patience.

Kind Regards,

Hi Comodo Support,

I have been searching for this post, as I am having the same isssues - but, only effecting Windows 7 OS’s! I have 2x Windows 7 Pro 64-bit and 1x Windows 10 Pro 64-bit computers and the Windows 7 computer have become a nightmare since the v10.0.1.6223 update!!

Having to wait approx. 1-2 mins for the Welcome Screen to actually show the User Names, and, when the do show, I get the same as already pointed out by @ComGer !

But, with my Win 7 computers, its been slowing them right down too and there fairly good spec machines!

Am I going to have to uninstall CIS v10.0.1.6223 and look elsewhere? I hope not :frowning:

Oh, and just to confirm; I have even completely reinstalled one of the Windows 7 computers, from scratch, processed ALL Window Updates, then installed fresh copy of CIS 10, but alas, same result!

Please check issue with

Thanks @futuretech!

I shall go to the link and read through!! :slight_smile:

Hi Comodo / Futuretech,

Okay, since this morning read the post about v10.0.1.6246, which I downloaded. I have a laptop, which I completely removed Comodo IS Premium and all my settings.

Restarted the computer. Carried out CClean and quick Defrag.

Then, created a Restore Point, ready for Comodo ISP V10.0.1.6246, then installed Comodo ISP.

Well, its now 16:04 (4:04 pm, UK time), sadly the Windows 7 Pro OS and laptop, is just as slow with the previous version of Comodo ISP and take nearly 1 min 30 sec before the Welcome/Logon Screen appears, for me to actually Log In to Windows.

Can I revert to an old version of Comodo ISP, prior to v10.0.1.6223, which I knew worked and was stable? If yes, where can I get this download file from, please?

Otherwise, sadly, I shall have to remove Comodo and look elsewhere. :frowning:

Though I am using this ‘free’ version, I would be prepared to ‘pay the subscription’ for the software, if I knew it would ‘fix the problem(s)’!

Thanks for your help in this very frustating matter!! :frowning: :frowning: :frowning:


sorry but the problem is still here.
the cistray.exe don’t start with windows => need to launch in manual each time
the windows service “theme” for aero theme don’t start 3 times on 4

Please check with thanks.

This version fixed my issue with connecting to a windows service. Thank you!