CIS Failed to Connect To Windows Service

Updated on Friday 4/7/17 CIS to after being notified by CIS that an update was available.

Machine is a Windows 7 Pro

After install/reboot get the following error message:

Error makes the PC unusable - Have to uninstall CIS to use the PC(Message then goes away).

Tried clean install yesterday with the same results.

Is anyone else having this issue? Is this a known issue?

Is there a place to download the previous version of CIS until the current issues with are resolved?

Thank You for any help you can provide


Hi Kanekid,

Thanks for reaching us.Please provide your diagnostic report, we need for further inverstigation.

Kind Regards,


Thank You for the response

I had to re-install CIS this morning to try and provide the doc you wanted.

Sorry, I don’t see where to pull a diagnostic report.

Attached are all of the logs I could find in your software

If you can provide a link on how to create the diagnostic report in this version of your software, I can provide

Thank You for your help

Happy Easter

Open the main interface and click the ? symbol then go to support and select diagnostics. Once it finishes click create report, choose location to save then attach the zip here. Also do you happen to have comodo Internet Security Essentials installed? If yes try to uninstall it then reboot to check if issue persists.


Attached is the file

The only thing listed in the Microsoft Uninstall Program screen by Comodo is:
Comodo Internet Security Premium


This is exactly the same problem three (3!) Windows 7 Pro machines I have are suffering currently, so I’ll be keeping tabs on the thread. Noticed the hotfix is out, going to try that…

I am experiencing the same problem on a machine running Windows 7 ultimate. Attached is diagnostic report.

To solve the problem: you need to find that unstarted service - and add its related file to “Comodo - Advanced Protection > Miscellaneous > … Exclusions

Please check again with version thanks.

Yes, the latest version appears to have stopped this error now. However my W7 Pro laptop is still taking an age going from the initial blue screen “Please Wait” to actually being able to log in. It started immediately after I upgraded to version 10. Any thoughts?

Tried updating to - Got same error message - Failed to connect to Windows Service ( See UPDATE Diagnostic)

Uninstalled Comodo and did a clean install from file from website - Got same error message - Failed to connect to Windows Service ( See CLEAN Diagnostic)

Thank You for any help you can provide

I can confirm that this bug is still alive even after removing CIS and following a clean installation (version on Win 7, 64bit).

This is quite an inconvenience due to the fact that you have to be an administrator to even access a profile.

Other than that, the latest update seems to have solved the other issues (CIS failing to start occasionally and creating desktop shortcuts).

For those having this issue can you provide details of each specific version of Microsoft .NET Framework that is installed? I think I know the cause but I need to know version of .net framework to be sure.

Hi Futuretech:

I have 2 identical hardware PC’s Running Windows 7 Pro (Different software applications and different usb attached devices)

When updating to Comodo 10.
PC#1 Got error “Comodo Security Agent could not be started” which has now been fixed with

PC#2 got Error “Failed to Connect To Windows Service”

Attached is screen shots from PC#1 and PC#2 showing the version of .Net installed

As one of the other Clients mentions, the “Failed to Connect To Windows Service” pc take at least 10 times as long to boot and 10 times as long to shutdown as the other PC with Comodo 10 installed

Please let me know if you need additional information.

Thank You for your help

Wanted to add my versions as well (see attachment). Thanks for looking into it.

Well there goes my theory as you are using the same version on the good and bad PC. I don’t know what to say considering its only happening on that specific system. Try adding the all applications file group to detect shellcode injections exclusions and reboot to see if error goes away.

Is everyone using username/password to log-in? Are you a limited user or administrator?
Also, provide all event logs.

Hi Futuretech:

Thank You for the information.

I disabled “All Apps” in the Shell Code Injection Protection as suggested and No longer receive the “Failed to Connect” message.

The PC appear to be running much faster also

Attached is a diagnostic report I ran after making the above change, not sure if it will be helpful.

Thank You for your help

Using a blanket rule is always at least a bit dangerous. You will be better off by disabling the Detect Shellcode Injections.

Can you also check Windows Event logs to see what Windows component gets effected? That way Comodo will learn what got effected.

Shellcode Injection Detection is always enabled. What the checkbox does is enable/disable exclusions. It will be changed/renamed with next versions to be clear. Excluding all applications is very risky, not recommended.