CID On Windows 8 Pro 32bit

I took the ‘plunge’ and have moved from Vista :-[ to Windows 8 Pro :-\

After installing CIS 6 to test I then installed CID, but no matter what settings I changed it still kept coming up saying that CID is not the default Browser when ever I ran it.

Thinking that CIS 6 was causing the problem being a beta, I re-imaged the pc to clean state and then installed CID as the only additional program, checked the settings in Control Panel, restarted the PC, but still no joy, it’s still saying that CID is not the default Browser :cry:

Has any-one else had the same problem setting CID or another Browser as the default on Windows 8?


Hi Dolphin66,
Are you saying that even Set Default Browser In Windows 8 For Links From 3rd Party/Desktop Apps instruction doesn’t work?
Checked with FFox on Win 8 x86 & that went well

Never tested CIS 6 beta on Win 8, but I have doubts including the fact that CID itself works, as far as I understand from your post, but cannot be set as default.
I would be ■■■■■■ if beta 6 does just “this” lil thing to CID :slight_smile:

If the tip mentioned above doesn’t help it’s most likely some kinda CID-Win 8 compatibility issue

Have you tried set it “without CIS”, as a matter of fact?


Hi SiberLynx,

Thanks for the feedback.

After playing around last night ( No CIS 6 - just Windows Defender and built in Firewall ) I found the following:-

When installing CD or another Browser from the ’ Browser Choice Screen ', at the end of the installer when you click on finish you get a Window to set your default Browser - Screenshot 1 - then you get an Option Box that says " How do you want to open this type of link (http)? - Screenshot 2.

When installing CID at the end of the install, the Window opens for setting Default programs in the Control Panel and not the Window as above, then after setting CID as the default - Screenshot 3 - when running CID the ‘nag’ box appears saying that CID is not your default Browser - Screenshot 4.

By setting to have CID NOT check if it is the default Browser, the ‘nag’ screen does not appear, BUT I wish to know if a setting has been changed so for me this is not an ideal solution and if other people install CID and keep getting the ‘nag’ screen they may think there is a problem and so un-install CID.

So it seems as tho Windows 8 is not happy with you wanting to use your own choice of Browser other than the ones that they have been " told " to include in the Browser Choice Screen?

[attachment deleted by admin]

Hi Dolphin66,
Have you tried setting another browser to be default and then going back to IceDragon to reset it as default from within IceDragons GUI?
Options, Advanced, General, System Settings.

Hi captainsticks,

Thanks for the suggestion.

Restored back to a clean install of Windows 8, then chose COMODO Dragon as the default Browser and no problems :-TU

Then installed CID and changed the settings during the install and the Control Panel after, but unfortunately still no joy :frowning:

For some reason Windows 8 >:-D does not seem to like CID ???

Hi Dolphin66,
Sorry my suggestion did not help and also I can not help reproduce as I do not have Win 8.
Let us hope someone has an solution or future versions to have a fix.

Edit: As a possible workaround right click your IceDragon shortcut go to properties and in the target field add a space then add or copy/paste the following line to the existing target, apply, OK.

Hi captainsticks,

Thanks for your edited suggestion :-TU

With a new version of CID now released I shall give that a try, if not I’ll add the text to the shortcut target :slight_smile:



This issue will be addressed in the next release.


You are welcome.

Hi George-Silviu Blendea,
Thank you for this information.

@ captainsticks,

As there has been a post from George-Silviu Blendea about the next version I shall persevere with the current situation till then ;D and thank you for your help :-TU

@ George-Silviu Blendea

Thank you from me as well :-TU