Chromodo Crashes - Won't Start - Fresh Install

Installed Comodo Firewall last week. Attempted to run Chromodo first within Sandbox from the widget, then unsandboxed. Repeatedly crashed.

Tried renaming Default folder for corrupt profile. It came up for a second; well, a window asking to be default browser but crashed.

Disabled anti-virus, anti-malware. No impact.

Repeated corrupt profile fix to no avail.

Uninstalled with Revo Uninstaller cleaning registry keys. Downloaded again from MajorGeeks. No love!

This is on a desktop installation so don’t believe the DPI is the issue but will try to find a Chromodo V36. to see if that will run . Oh, the error message is simply:

Whoa! Chromodo has crashed. Relaunch now?

Followed by the following problem details:
Problem signature:
Problem Event Name: APPCRASH
Application Name: chromodo.exe
Application Version:
Application Timestamp: 5559eeec
Fault Module Name: chromodo_s.dll
Fault Module Version:
Fault Module Timestamp: 5559ee9f
Exception Code: c0000005
Exception Offset: 007253b3
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
Windows 7 Privacy Statement

If the online privacy statement is not available, please read our privacy statement offline:

Ah, it seems that it is the new version only. Installed Comodo Dragon V36 and it runs; however, if allowed to update to new V42 it crashes as well (surprised there was an update, thought Chromodo was replacing it. So, will remain on V36 of Dragon.

Couldn’t find a V36 source for Chromodo. As it seems Chromodo merely repackaging of Comodo anyway, but the new Comodo V42 shares the same issues as Chromodo V42. Don’t know if it’s the same DPI issue as this is a desktop but perhaps.

Will wait for V43 to update.

Just installed Chromodo V43. Works like a charm! 8)

Amusing and useful install helper popups when downloading adobe flash.

Definitely solved the V42 bugs that kept crashing!