Chromodo Crashes Upon Second Use

Chromodo functions normally after being downloaded, installed, opened, and run.

But only once.

If Chromodo closed and restarted it crashes on second and subsequent attempts.

What follows was first PM’d to AEK and edited here in (I believe) the appropriate thread.
It outlines in detail the problem.


To forum members following this thread,

CIS Pro was recently downloaded, installed, activated, and ran.

Initial scan removed 9 security threats and Comodo Internet Security Pro software guarantee warranty was confirmed.
The CIS Pro download includes Chromodo (with an H, not to be confused with Comodo Dragon).

Chromodo (latest official released version) launches (opens and runs) satisfactorily when the launch option is left checked upon completion of download and the download ‘Finish’ button is clicked.

When Chromodo is closed and reopened (to see if it will start and run again) using either the Window 8.1 ‘Desktop’ or ‘Metro’ icons it crashes.

A corrupted download was suspected, so Chromodo was uninstalled (properly) through use of Windows ‘Control Panel’ and ‘Programs and Features’.

An official Comodo download link for Chromodo was obtained and Chromodo was installed again.

There was no change to how Chromodo behaved.

It opened (launched) and ran upon completion of the download.

No apparent problems witnessed until Chromodo was closed and restarted.

A Windows dialog window appears titled ‘Chromodo’ that states:

“Chromodo has stopped working
Windows can check online for a solution to the problem.
Check online for a solution and close the program
Close the program
View problem details”

Clicking ‘View problem details’ yields:

“Problem signature:
Problem Event Name: APPCRASH
Application Name: chromodo.exe
Application Version: 42.1.2.90
Application Timestamp: 5559eeec
Fault Module Name: chromodo_s.dll
Fault Module Version: 42.1.2.90
Fault Module Timestamp: 5559ee9f
Exception Code: c0000005
Exception Offset: 007253b3
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 1033
Additional Information 1: 5861
Additional Information 2: 5861822e1919d7c014bbb064c64908b2
Additional Information 3: a10f
Additional Information 4: a10ff7d2bb2516fdc753f9c34fc3b069”

From this ‘details’ report can it be determined what the problem is that is causing Chromodo to function correctly as a browser, but only on the first instance?

The machine (system) being used is a Dell 13-7347 ‘2-in-1’ laptop running Windows 8.1 (64 bit).

Everything else is running satisfactorily on this machine.

A ‘user profile’ in Chromodo was not setup during the first instance of it running.

Could this be the reason for Chromodo crashing on its second opening?

Maybe others on this thread have already experienced this problem and know a solution.

If so, this would same time researching the problem and finding its resolution.

Any help that can be offered is greatly appreciated.

BooII


Hopefully someone on this thread already knows of this problem and its solution.

BooII

We will investigate this surely.

Hi Guys,
I am not sure if it helps, but I can reproduce the 'APPCRASH’ event with Chromodo Version 42.1.2.90 if I set my system DPI at 150% or above.
Not sure if this is the case for BooII as I don’t know his settings.

Note: Dragon Version 36.1.1.22 can still function correctly with this DPI setting.

Kind regards.

Since upgrading to 42.1.2.90 I now get this problem on my Surface Pro running Windows 8.1 64bit.

I am running the same version of Chromodo on my PC, which also runs Window 8.1 64bit, without issue.

Chromodo just ends up in a crash loop, asking i I want to relaunch, crashing, asking if I want to relaunch, crashing, etc… I can’t initiate the program at all.

Event viewer says:

Faulting application name: chromodo.exe, version: 42.1.2.90, time stamp: 0x5559eeec
Faulting module name: chromodo_s.dll, version: 42.1.2.90, time stamp: 0x5559ee9f
Exception code: 0xc0000005
Fault offset: 0x007253b3
Faulting process id: 0x1148
Faulting application start time: 0x01d098f886ed42b1
Faulting application path: C:\Program Files (x86)\Comodo\Chromodo\chromodo.exe
Faulting module path: C:\Program Files (x86)\Comodo\Chromodo\chromodo_s.dll
Report Id: c4da2eea-04eb-11e5-bebd-281878416fb8
Faulting package full name:
Faulting package-relative application ID:

Chromodo also crashes for me after upgrading to the latest version , but works when I revert to Version 36.7.0.8 Chromodo

I noticed the comment regarding the DPI setting. I am running at 150% on Windows 7 Ultimate with Comodo Internet Security installed.

■■■■ on right. I have the same problem. Updated CD and haven’t been able to launch it even once. Using 150 DPi settings for text.

Switched to 125DPi and it runs without any issues.

Please fix this guys. I have old eyes and need to use 150DPi. Unable to use CD till such time as this issue is fixed.

I am having the same problem with the current versions of Dragon and Chromodo. 150% dpi it crashes on start, 125% dpi it is fine. Being that I am running a 55 inch 4k display, its to small at 125%, so I would love it if this was fixed so I can use these browsers again.

Dragon suffers from this too - but you gave me the clue on how to fix it.
Now Dragon works for me. It’s fuzzy - not High DPI. But it’s not crashing.

To make Low DPI apps work on High DPI displays (like my Surface Pro 3), you have to do two things.
(I use it on Photoshop, MindManager, etc. to make buttons clickable).

Follow this tutorial, or read on…

One is create / edit this registry key “PreferExternalManifest” in here:
HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > SideBySide

Make a new [DWORD32]
Called PreferExternalManifest
Make sure PreferExternalManifest = 1

I don’t believe you need to reboot.

Then create an external Manifest file in the same folder where dragon / Chromodo is installed using Notepad:
dragon.exe.manifest (make sure it does not have a “.txt” extension when you’re done)

Copy this XML into Notepad, save it as “dragon.exe.manifest”:


<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">

<dependency>
  <dependentAssembly>
    <assemblyIdentity
      type="win32"
      name="Microsoft.Windows.Common-Controls"
      version="6.0.0.0" processorArchitecture="*"
      publicKeyToken="6595b64144ccf1df"
      language="*">
    </assemblyIdentity>
  </dependentAssembly>
</dependency>

<dependency>
  <dependentAssembly>
    <assemblyIdentity
      type="win32"
      name="Microsoft.VC90.CRT"
      version="9.0.21022.8"
      processorArchitecture="amd64"
      publicKeyToken="1fc8b3b9a1e18e3b">
    </assemblyIdentity>
  </dependentAssembly>
</dependency>

<trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
  <security>
    <requestedPrivileges>
      <requestedExecutionLevel
        level="asInvoker"
        uiAccess="false"/>
    </requestedPrivileges>
  </security>
</trustInfo>

<asmv3:application>
  <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
    <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware>
  </asmv3:windowsSettings>
</asmv3:application>

</assembly>

This works with any application that is too tiny to use your stylus / finger with on a High DPI display.
Just copy / rename the Manifest correctly.

Hello everyone,

We reproduced the issues that you sent us, and we’ve found the root cause. One of our colleague immediately started to fix it. v43 is already on his way, and we’ll add this fix in v43. Thanks for your valuable feedback, I personally appreciate your contributions to make our browser much better.

Thanks.