Chromium engine gets v slow within the CIS Sandbox (input lag/delay) [M326]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can you reproduce the problem & if so how reliably?: Yes and 100% reliable on my own system.
  • If you can, exact steps to reproduce. If not, exactly what you did & what happened:
    I don’t know the exact chromium versions, but whichever chromium version Comodo Dragon V23.4 used worked fine, but every version after V24.0 has this issue, so:
  1. Download any browser using a chromium version which is the same or later of that of Comodo Dragon 24.0
  2. Run it inside the sandbox (fully virtualized)
  3. Go to any website and try scrolling, also try highlighting text, everything within the browser is slow as if there is a ~500-1000 ms delay.
  • If not obvious, what you expected to happen:
    I expected everything to be instant, as when you use the browser outside of the sandbox.
  • If a software compatibility problem have you tried the conflict FAQ?: I read the FAQ and it did not seem to apply to this issue.
  • Any software except CIS/OS involved? If so - name, & exact version: Any chromium browser using a version equal or later of that which is present in Comodo Dragon V24.0
  • Any other information, eg your guess at the cause, how you tried to fix it etc: My guess is a change in how chromium does things and whatever it changed, the sandbox did not like. This is not accompanied by high CPU usage.

While sandboxed, under flags if “GPU compositing on all pages” and “Threaded compositing” is disabled the browser will be much quicker. This may be helpful when identifying the problem.

  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not malware)
    A full dump, run while the slowdown is occuring, is attached to this post.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS version 6.0.264710.2708, configuration does not matter, all you need to do is sandbox the browser.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:HIPS - Safe, BB - off, Firewall - Custom, AV - on.
  • Have you made any other changes to the default config? (egs here.): Yes, a lot, though it should not matter.
  • Have you updated (without uninstall) from a CIS 5?: No.
    [li]if so, have you tried a a clean reinstall - if not please do?:
    [/li]- Have you imported a config from a previous version of CIS: No
    [li]if so, have you tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 8 64bit, UAC - off, Account - Administrator.
  • Other security/sandbox software a) currently installed b) installed since OS: a= Window Defender? b= Windows Defender?

[attachment deleted by admin]

Video: - YouTube
Warning: “Foul Language”, While recording I was still trying to figure out when exactly the problem occurred. The video is as of now sort of outdated, so any settings etc seen in this video might not be the same now though the issue is still present.

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

A.8 Your complete ‘Watch activity’ process list while this problem is occurring showing CPU and memory usage columns. You can get this by setting Killswitch to replace your windows task manager on the Killswitch options menu, and right clicking on the task bar in Kiosk.

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


I will attach it both in this post and in the original post, though I’m not using Kiosk.

Edit: Though as far as I know, this is probably occurring for everyone, if you have time and if you have either latest dragon or chrome installed, could you try launching it outside of the Sandbox then going to any website(not dragon or chrome settings) and then try to highlight some text with your mouse? This is pretty instant yes? As the blue highlight is right at the cursor instantly. Now do this inside the sandbox (fully virtualized) and you should see that the blue highlight isn’t right at your cursor instantly, rather it traces after your cursor.

Though this isn’t just an issue with highlighting, it’s just the most obvious one, you can also test scrolling etc. I think it applies to anything being rendered or something like that. Perhaps a change within the chromium engine on how it renders things?

[attachment deleted by admin]

Thanks Sanya clarification etc much appreciated

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


This has NOT been fixed in CIS Version 6.1.275152.2801.

Thanks for the info, I will update tracker. Do you get high CPU with this?

No I do not get a high CPU usage.

I am also having a speed issue with Chrome running in the sandbox.

Chrome v26.0.1410.64 m
Comodo: v6.1.276867.2813
OS: Win7 Home Prem
Outide of the box Chrome’s nice & fast. Inside the box pages take so long to appear that I get the ‘Page has Become Unresponsive’ dialogue nearly twice. Once up though they don’t seem too bad (until I try to open another)

Still not fixed in .2813

Thanks Sanya. Tracker updated

Not fixed in 6.2.282872.2847

Thank you for checking this.

I have updated the tracker.

Due to the issue detailed in this bug report by me, I can no longer check whether or not Google Chrome engine is slow within the FV sandbox, however Opera 15 uses the blink engine and that is not slow within the FV Sandbox, whenever Comodo Dragon updates to the blink engine I will try that one too.

I forgot to also mention that the versions of Comodo Dragon that are not using blink yet (latest version so far is 27.2) are still affected by this and are slow. I think that whenever CD is updated to the blink engine it will either run smoothly or it won’t run at all in the CIS sandbox.

Update: apparently Google Chrome showed up after a very long time when running it in the FV sandbox and after it ran it was very slow, perhaps even more so than before.

[at] the devs, this other (likely related) issue is reported here.

I was playing around with Opera Next 16 when I noticed something. While sandboxed, under opera://flags if “GPU compositing on all pages” is changed from Default to Enabled then the browser will become a little sluggish, when “Threaded compositing” is changed from Default to Enabled the browser acts just as slow as Chrome in the sandbox. When both of these are set to “Default” it works fine in many pages but pages like youtube (must be a video) will be kind of sluggish but not as bad as with the settings set to Enabled.

Did you try with those flags disabled in Chrome (chrome://flags)?