Chemcraft does not run if Comodo 5.0 is installed

The bug

  1. What you did: I updated Comodo Firewall from version 4 to version 5 through a complete install and reinstall, then tried to run a chemistry-related program, ChemCraft.
  2. What actually happened or you actually saw: ChemCraft, which was running fine with Comodo Firewall 4, is not running at all with Comodo Firewall 5, it does not even show its splash screen.
  3. What you expected to happen or see: The expectation was that the program would run normally, just as with Comodo Firewall 4.
  4. How you tried to fix it & what happened: I uninstalled Comodo Firewall 5, found out that ChemCraft was running again properly without Comodo Firewall 5, then re-installed Comodo Firewall 5 and established that ChemCraft was not running again.
  5. Details (exact version) of any software involved with download link: Chemcraft_b332_win.exe, Chemcraft - Download.
  6. Bugzilla id (mods use only):

Files appended

  1. Screenshots illustrating the bug: Not available.
  2. Screenshots of related event logs or the active processes list: There are no entries in any of the Comodo logs associated with the failure of ChemCraft to start.
  3. A CIS configuration report: Not available
  4. Crash or freeze dump file: Not available

Your set-up

  1. CIS version & configuration used: Comodo Fireall 5.0.162636.1135, Firewall security.
  2. Whether you imported a configuration, if so from what version: No
  3. Defense+ and Sandbox OR Firewall security level: Defenseplus=Safe, Sandbox=disabled
  4. OS version, service pack, bits, UAC setting, & account type: Windows 7 Professional, N/A, 64 bit, Default, Admin account.
  5. Other security and utility software running: Avira Antivir Premium v10.0.0.603
  6. CIS AV database version: Not applicable

Good title but please edit your post to reflect the bug report format here.

Please cut and paste the format and use it as a template

Regrettably we are not permitted to move your post to the ‘moderator verified issues’ topic unless in standard format with all relevant information provided, so it may not be actioned if you don’t.

Best wishes

Mike

Please also try listing this under buffer overflow exclusions in Defense plus ~ Defense plus settings ~ image execution control. Then reboot and re-try.

Many thanks—this has sorted it out.

OK thanks for reporting in the correct format anyway. An excellent report!

I’ll move this to help later to assist others if that’s OK

Mouse

Certainly, this is a good idea.

However, it would have been nice to see something in the Defense+ logs which would indicate that the program was triggering a buffer overflow.

Many thanks again for your help with this problem.

It would, if it were, but it isn’t :slight_smile:

Buffer overflow protection exclusion also lifts the app from the wider control of guard32.dll. That’s what is solving it!

You do get alerts for BO!

Best wishes

Mouse