Changes to D+ and firewall rules intermittently forgotten [V6][M222]

I thinl it’s not necessary an Issue report. As by title: I use Seven Home Premium SP1, updated. I’ve used CIS 6 for two weeks, and it doesn’t keep in memory many rules that I create in Defense+ ( Paranoid mode, sandbox disabled ). I change an existing rule of an application or a service in Settings, I save it and it works, but often at the first reboot the rule is back to the previous state. I like CIS 6, and I appreciate the great work of Comodo in developping this version, but for the moment I came back to 5v.

I’m afraid it is needed if devs are to have the best chance of fixing the bug, which seems an important one.

We explain why these reports are necessary here.

Many thanks for your help in anticipation.

Best wishes


Thanks very much for your issue report, which is much appreciated.

We have moved it to the non-format bugs board for the moment, because too much of the information we normally need to replicate a problem and fix it is missing, or it is not in the format we request.

We realize some people may not have the time to do an issue report in standard format, and therefore offer the option of a non-format report instead. But the problem is much more likely to be fixed promptly if you edit your first post to create an issue report which reflects the guidance in the Standard Format topic. (You can copy and paste the format from this topic). The reasons we ask for the information we do are given in this post.

You can get your report moved to the format verified issues board simply by ensuring that it reflects the guidance in the standard format topic, and PM’ing a mod who is active on the bug board.

Best wishes


A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- What actually happened or U actually saw: Defense+ and FW don’t keep in memory all the change in rules: after I saved the change some rules remain as it were before my action.

  • If not obvious, what U expected to happen or see:
  • Can U reproduce the problem & if so how reliably?:
  • If you can, precise steps to reproduce it. If not say what you did before it happened: simply, sometimes I change single rules of applications that I already created in Defense+ or in Firewall.
  • If a software compatibility problem have U tried the conflict FAQ?: no, it’s not a software compatibility.
  • Any software except CIS/OS involved? If so - name, exact version, & download link: GesWall 2.92 ; I used it since CIS 4 version and I never had conflict problems.
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Always attach: Diagnostics file, Killswitch processes, dump (if freeze/crash). If complex: CIS logs & config, screenshots, video.

B. YOUR SETUP (Likely the same from issue to issue, users can copy forward)
[ol]- CIS version & configuration:COMODO Internet Security 2013 v 6.0.260739.2674

  • Modules enabled & level. Defense+/HIPS, Autosandbox/BBlocker, Firewall, & AV:Defense+ in Paranoid Mode - Autosandbox/BBlocker disabled - Firewall in Custom ruleset - AV On Access.
  • Have U updated (without uninstall) from a previous version of CIS:no, I uninstalled the previous version of CiIS.
    [li]if so, have U tried a a clean reinstall - if not please do?:yes , issue not solved.
    [/li]- Have U imported a config from a previous version of CIS:no, I setted it after the new installation
    [li]if so, have U tried a standard config - if not please do:
    [/li]- Have U made any other major changes to the default config? (egs here.): no
  • OS version, SP, 32/64 bit, UAC setting, account type, & virtual machine used :Seven home premium SP1 - account admin - UAC disabled - no virtual machine.
  • Other security & sandbox software a) currently installed b) installed since last OS install:GesWall 2.92

So, hope it’s useful. Thanks for your help.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Sorry to trouble you further, but I cannot make this happen on my machine

Could you give the exact sequence you go through to change these rules, bluevick? What dialogue, what exact steps. Do you always press OK on both the rule and the advanced settings dialog afterwards?

Do they always fail to save? Or just sometimes? When they fail to save is there any common factor?

Do any of the rules relate to networked apps or apps on removable drives?

Best wishes


Thanks Bluevic. Could you add a screenshot of your Killswitch processes and a diagnostics file please so devs can investigate.

When your saved changes fail, have you looked at the rules to see if they have reverted to their original form?

Best wishes


Ya, every time the rules reverte at the original form.

Sorry, how can I sent the file ?


If a jpeg, just append it, otherwise zip it

Sorry, as it’s the first time that I send file in Comodo Forum, I mean: all Forum’s users will see my jpeg and diagnostic file ?

If you like you can put it in a password protected zip file and attach that. Just make sure to say in your post that the devs can PM you for the password. That way they will have access to the files, but nobody else can see them.

Well, so the diagnostic file of KillSwitch and two screenshot. To devs or Mods, please, PM for the password. Thanks for your help.

[attachment deleted by admin]

Thanks bluevik, much appreciated


bluevik confirms here that he still has this issue with 2708. In fact, he says that it is now worse.

Ya, thanks for your attention :). With the previous version my problem seemed stabilizing, but every time I come back to it, then the updater works outside my settings.

Tracker updated, thanks Chiron and BlueVik.

If you see another user with exactly the same problem please post a link

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.